x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Game Center/Google Play stopped connecting

Not sure what changed to break it, but previously I was able to log into Game Center fine when launching an iOS game, and now I can't. I've tried this with multiple projects, including Tappy Chicken, on both a PC and a Mac, in both 4.10 and 4.11. Game Center will never connect. The "Show external login UI" node always returns a failure. I pulled the full version of my project from iTunes using TestFlight, and Game Center was also failing in that. I tried downloading the full version of Tappy Chicken from the App Store, and Game Center worked in it. It's only failing in projects that I either launch or package from UE4 myself.

-Edit- Android seems to be doing the same thing with Google Play, again not limited to a single project. Also interesting is that banner ads are working fine.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 25 '16 at 09:43 PM in Using UE4

avatar image

Grimwolf
157 15 19 27

avatar image Grimwolf May 04 '16 at 11:58 PM

I've made some progress on this issue. It seems the problem, at least for iOS, was me converting it into a C++ project. Apparently this will stop game center from working, unless certain code is added to the target.CS. It was recommended to get this code from the unreal match 3 project, so I just copied it over and changed the project references. Now though, the project will not launch at all, and I don't understand the issue referenced in the log.

-Log to follow-

avatar image Grimwolf May 05 '16 at 12:01 AM

LogPlayLevel: Automation.Process: Setting up command environment.

LogPlayLevel: Automation.Process: Compiling scripts.

LogPlayLevel: BuildCookRun.SetupParams: Setting up ProjectParams for /Users/grimw/Documents/Unreal Projects/DapperBat/DapperBat.uproject

LogPlayLevel: DynamicCompilation.CompileAssembly: Messages while compiling /var/folders/mm/6bmx378s5255q0dgf5txh0pw0000gn/T/UAT/+Users+Shared+UnrealEngine+4.11/Rules/UATRules935126411.dll:

LogPlayLevel: DynamicCompilation.CompileAssembly: WARNING: /Users/grimw/Documents/Unreal Projects/DapperBat/Source/DapperBat.Target.cs(26,26) : warning CS0672: Member DapperBatTarget.GetModulesToPrecompile(UnrealBuildTool.TargetInfo, System.Collections.Generic.List)' overrides obsolete member UnrealBuildTool.TargetRules.GetModulesToPrecompile(Unrea lBuildTool.TargetInfo, System.Collections.Generic.List)'. Add the Obsolete attribute to `DapperBatTarget.GetModulesToPrecompile(UnrealBuildTool.TargetInfo, System.Collections.Generic.List)'

LogPlayLevel: DynamicCompilation.CompileAssembly: ERROR: (0,0) : error : /Users/Shared/UnrealEngine/4.11/Engine/Binaries/DotNET/UnrealBuildTool.exe (Location of the symbol related to previous warning)

LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: ERROR: UnrealBuildTool encountered an error while compiling source files

LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)

LogPlayLevel: Domain_ProcessExit

LogPlayLevel: Completed Launch On Stage: Build Task, Time: 6.396360

LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.

PackagingResults:Error: Error Launch failed! Unknown Error

I think this is saying the issue is on line 26 of the target.CS, which looks like this;

public override void GetModulesToPrecompile(TargetInfo Target, List ModuleNames)

avatar image Grimwolf May 24 '16 at 10:07 PM

I added this code to the build.CS, and game center will now run, but ads will not. Whether it's the built-in banner ads or ones from the universal mobile ads plugin, the log says that the ads could not be found and nothing shows up in game;

     if ((Target.Platform == UnrealTargetPlatform.IOS))
     {
         PrivateDependencyModuleNames.Add("OnlineSubsystem");
         DynamicallyLoadedModuleNames.Add("OnlineSubsystemIOS");
         PrivateDependencyModuleNames.Add("Advertising");
         PrivateDependencyModuleNames.Add("IOSAdvertising");
     }


I've been able to confirm that the issue was with the project itself, and not with my ad network set up. The only documentation I could find on this said that I need to add certain code to the target.CS, just as I posted earlier. Again though, this prevents it from launching.

Interestingly, it turns out that the Unreal Match 3 project will not launch either. It has the same issue created by adding the suggested code.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question