Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is Mesh Streaming Distance not working correctly with scaled meshes?

We have hundreds of meshes from Unity that have been imported in UE4. We changed the Mesh Build Scale to 100 100 100 .

Because of that the textures streaming distances are wrong; textures look blurry unless we are realy close to the object. Its possible to fix this by changing the Streaming Distance Multiplier on the mesh property matrix but I'm not sure if its the proper way.

Shouldn't Unreal engine do this internally for custom build scaled meshes? The reason why I ask this is because I notice now that although the textures are being streamed properly, the lightmaps are NOT (there are very noticeable lightmap pops now).

So I guess there are questions that need answers; 1. Is the texture blurryness a bug that should be fixed for meshes that have custom build scales or is this normal and we should manually go change the streaming distance multiplier? 2. Are the lightmap pops a bug that should be fixed for meshes that have custom build scales or is there a parameter somewhere like the Streaming distance that should be setup?

Thank you

Product Version: Not Selected
more ▼

asked May 08 '14 at 08:56 AM in Rendering

avatar image

625 40 61 80

avatar image bigzer May 14 '14 at 10:26 AM

Any chance to get some feedback about this?

avatar image Lovecraft_K ♦♦ STAFF May 14 '14 at 08:58 PM

Hey bigzer -

Would it be possible to get a mesh and texture that are causing your issues so we can more accurately reproduce your problem? (Any mesh or texture even a sample one would work.) I am asking because I am unsure of the scale of the original model and am having a hard time replicating the issue.


-Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey bigzer -

I wanted to touch base and see if this issue has been addressed with you. While the best solution is to reexport the mesh, but try to adjust the Auto Distance Scale setting in the Static Mesh Editor >> LOD Settings >> Auto Distance.


Eric Ketchum

more ▼

answered May 21 '14 at 02:26 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image TheSubZer0 Dec 24 '18 at 02:17 AM

Where's that option?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question