x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.11.2 Vr preview greyed out

Hello, I am new to the unreal engine but not to VR and the oculus series. I am unsuccessfully trying to run a DK2 runtime 1.3 with unreal 4.11.2 on a windows 7 machine. Whatever I do, I get the "VR preview" option greyed out which is insane because I though 4.11 was all about VR dev. Sooooo if anyone has a solution?

Things I've tried Uninst and reinst Oculus runtime 0.7, 0.8, 1.3 Shut down & restart Oculus runtime Update GPU drivers

Product Version: UE 4.11
Tags:
more ▼

asked Apr 26 '16 at 05:46 PM in VR

avatar image

Vincent.rieuf
1 1 2 2

avatar image Jc_Smash Apr 28 '16 at 03:28 AM

I am getting the same problem. I can get the VR working in 4.10 but i still cant get it to work in 4.11

I have tried reinstalling the Oculus SDK (0.8).

I had it working in 4.11.1 but for some reason cant get it to work in 4.11.2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

You have to start the oculus desktop app first and turn the rift DK2 on. Than start UE4 v4.10.4 as a test. If this works try on 4.11. I got same problems with the 4.11 version. 4.10.4 works fine.

more ▼

answered Apr 26 '16 at 09:36 PM

avatar image

daJhoony
11 1 3

avatar image Vincent.rieuf Apr 27 '16 at 11:05 AM

Ok tried it, and it worked! Weird but true. Thx man

avatar image daJhoony Apr 27 '16 at 01:49 PM

You are welcome! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've tried this and it doesn't work for me. It works on 4.10.4 but it's greyed out in 4.11.2

more ▼

answered May 04 '16 at 02:34 PM

avatar image

JavierRamello
71 6 10 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had the same issue. This was a Unicode problem in my case. When UE4 installed on Windows it can work only with English characters. It is ancient bug.

So, what I've done to make it work: 1. Uninstall Engine, SteamVR and Steam or all Oculus software and clean registry 2. In Windows 10 go to Settings -> Time & Language -> Region & Language -> Set English language as default (install it if needed) -> click on "Additional date, time, & region settings" -> Region -> Administrative -> Copy Settings -> choose both check boxes and click Ok 3. In Region -> Administrative -> Change system locale -> choose English(United States) 4. If your current Windows user's name (account name) not in English language (my name was typed with Cirillic Alphabet) you should create new user in English 5. Relogin under new user then install all stuff again

This should work on Windows 7 too. Just keep in mind the main reason: characters Unicode problem

Maybe I made some extra steps to solve it. Maybe you don't need to change language for whole Windows, maybe it is enough to change "Current language for non-Unicode programs" option and set up new User in English, but i never checked it, because I feel comfortable with this settings

more ▼

answered Aug 04 '16 at 10:26 PM

avatar image

aitechtor
33 1 6

avatar image tomofnz Nov 26 '16 at 07:18 AM

This also was the fix for me in 4,14 win10 (commercial oculus, not dk2) The steps to get there are indeed a little step heavy... but it seemed to work fine. Thanks aitechtor

avatar image skymaphans Feb 15 '17 at 10:22 AM

I wanted to confirm that you do not need to do all these steps, it's enough to just change "Current language for non-Unicode programs" to English (USA). That's all I had to do anyway. I'm running Windows 10 Home in Swedish language and am using UE 4.13.3. Thanks for the help aitector!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question