x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sessions Hosting and Finding not working on steam published game

Hello All,

Right now we are having a lot of trouble trying to get our game on steam because of an issue on steam sessions. During development, we have been using the 480 appID with and we got the multiplayer hosting and finding lobbies to work flawlessly. However when we finally got our own appID, Sessions are not working anymore at all.

When creating a session (Either through C++ or blueprint, or even the advanced session plugin), nothing happens. We dont get a success or a failure callback, and as far as I could tell, no errors in the log. Same thing happens when we try to look for lobbies, nothing happens, both success and failure are not called on.

The steam overlay is working correctly AND showing the correct game name. From the logs, steam initializes fine and I cant seem to find the issue. Whats even more confusing, we are able to host dedicated servers and join them through console commands, just not lobbies.

We contacted valve, and they assured us that our appID has lobby support enabled for it. Which drives me to think maybe there is an issue with UE4, but I couldnt find any hint on what it could be. I am hoping for some help from the community to try and figure this out.

Attached below is our log.

link text

Product Version: UE 4.11
Tags:
more ▼

asked Apr 26 '16 at 10:44 PM in Using UE4

avatar image

Hassan El Habbak
1 1 2 4

avatar image State128 Apr 22 '17 at 05:39 AM

Hi, we have the same problem, but i get an error msg specific related to denial of creating lobbies. How did you get in contact with Valve? We have posted on their dev partner forum, but the response is weak. Is there another way to get help from valve? Atm we can't start our external testing due to this :(

Can i manually enable lobbies for my appid?

avatar image DecodeTM Oct 26 '17 at 03:02 PM

can we contact each other? https://decodestudios.in/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question