x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Failed to find shader map for default material WorldGridMaterial!

Hello everyone! I´ve posted this question on an existing thread in "Bug Reports" since the user was having exactly the same problem. But i dont think this is a bug but something i am missing. Anyways nobody could help this guy so i am posting again in the correct section...

I am trying to pack a simple architectural interior level. Everything runs ok while on the editor, no errors when building and no errors when packing the game. The problem comes out when we try to run the .exe file. I´ve attached a screen capture showing the error. I think we´ve tried almost everything, we´ve also merged all meshes, textures and materials into a new blank project with no success.

Hope someone could help us solve this. Let me know if theres any other relevant info i can give you so you can give me a clue of what´s happening.

Thank you all!!

Nico.-

alt text

Product Version: Not Selected
Tags:
error.jpg (127.0 kB)
more ▼

asked May 08 '14 at 01:32 PM in Packaging & Deployment

avatar image

nsbermudez
6 1 2 2

avatar image Syneh May 10 '14 at 08:26 PM

I'm also getting this error.

Launch log

Here is someone else with the same problem: https://answers.unrealengine.com/questions/23268/failed-to-find-shader-map.html

Edit 1: DxDiag

avatar image Syneh May 10 '14 at 10:43 PM

Edit 2: I managed to fix this by creating a new project and adding content from the old project to it. Packaged it and it's working fine now.

avatar image nsbermudez May 10 '14 at 10:25 PM

Hi Syneh. I think we found a solution for our problem...at least we could run our packages without any issues. The problem was solved since we restore default values on "Lighting" settings, under "Project Settings" >>> "Rendering". We were turning off static lighting since our illumination was completely burned in 3dsMax, so we didnt need any Unreal Lights in our scene...

I´m attaching an image showing the parameters that we have to left by default. Let me know if this solves your problem too so i can report it as a Bug.

Regards!

alt text

solution.jpg (209.4 kB)
avatar image Syneh May 11 '14 at 12:15 AM

Thank you. Yes, this fixed it.

avatar image nsbermudez May 11 '14 at 02:18 AM

Im glad to hear that. It would be great if someone from the staff could tell me if this thread is enough to let them know about this issue or if i should create another thread under "Bug Report".

(Sorry about my english...if something of what im writing is not clear just let me know so i can explain myself with other words)

Regards!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, could you please submit a new report for it.

Thanks!

more ▼

answered Nov 25 '14 at 03:39 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 76

avatar image JakeChoe Mar 23 '15 at 01:26 AM

I have same problem on 4.7.3 Binary version. I'm trying to pack for Android device and it occurs when it is run on device.

I attached logs.

logcat.txt uatlogs.zip

logcat.txt (30.9 kB)
uatlogs.zip (532.2 kB)
avatar image [Epic] Gribbs ♦♦ STAFF Mar 24 '15 at 08:53 PM

Howdy JakeChoe,

Thanks for the information about the issue that you have been experiencing. We has had other users experience issue with the WorldGridMaterial and have written Jira Report UE-12213 to track this issue.

A fix for the issue has been checked in yesterday (not verified yet) but should be placed into an upcoming release of UE4. I am unsure as to when or what version this fix will be implemented but I will be sure to keep you posted as I know more.

Thanks!

avatar image MaxSMoke777 Feb 17 '16 at 04:40 AM

It's almost a year later and I'm seeing the same bug (using ADB Logcat) in UE4 4.10. It seems to be the reason my Android build is failing.

avatar image Samantha Sutton ♦♦ STAFF Feb 19 '16 at 07:30 PM

UE-12213 was fixed in 4.7. If you feel that this issue is still occurring, it would be best advised if you created a new AnswerHub post with full details and any additional files/logs that would be necessary for investigation.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question