x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Keeps Losing Visual Studio; Can't package project

https://embed.gyazo.com/37489b630571fbab5348110b8983ff33.png ^ That location is correct.

This was happening before on my computer and I couldn't solve it at all so I had to completely reinstall Windows 10.

Got it working have a reinstall of W10. Then it stopped working so I had to repair it. Yesterday it stopped working and repairing it didn't fix it and I can't seem to figure out what's going wrong. I can still run Visual Studio just fine but Unreal can't find my install.

I try to Build for Windows 64 Bit and it says that Visual Studio 2015 can't be found.

I have Visual Studio 2015 Community with Updates (2) installed. Everything under C++ is installed along with C# modules and a couple other things (Windows Common Tools).

Product Version: UE 4.11
Tags:
more ▼

asked Apr 27 '16 at 08:21 PM in Packaging & Deployment

avatar image

Travistyse
78 5 11 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Disabling Substance worked.

Edit: Plugin 4.11.0.14 for UE4 4.11.2

more ▼

answered Apr 30 '16 at 09:46 PM

avatar image

Travistyse
78 5 11 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you tried restoring your system? It seems that something you install/use is messing with visual studio/unreal/registry. Maybe restoring your system to a state previous to your problem gets it fixed, and that way you could find out what's causing your problem.

more ▼

answered Apr 30 '16 at 07:10 AM

avatar image

Sveitar
1k 8 24 28

avatar image Travistyse Apr 30 '16 at 07:28 AM

The weird thing is that I don't have anything installed, really. I only reinstalled Windows about 10 days ago give or take. The only system restore I would have is likely the first time Visual Studio was installed (and on reboot it immediately stopped being detected) at best. If it was overwritten by the 30 other installs of VS then I won't even have that.

Not because I don't like having system restores. But because:

  1. Windows 10 did away with them or something. Can't seem to find any information on how to set one up or restore using it.

  2. In the past I ALWAYS created a system restore as soon as I have my drivers installed. And as soon as things go downhill I try restoring but it always fails so I have to reinstall anyway.

Edit: Derp. It's in the control panel. Wish Microsoft hadn't created "Settings" ; makes me forget that they both exist sometimes. No restore points though. So I'm going to try to "reset" Windows rather than.. or repair it. Whichever doesn't undo everything but does reinstall Windows.

avatar image Travistyse Apr 30 '16 at 11:53 AM

Complete reset of Windows.

Only thing I've installed is: Visual Studio Unreal Engine 4.11.2 Chrome AMD Drivers

And it still can't find it.

https://gyazo.com/9e9fb00c876218e64ce7cf185c798b2e

That said, I did have to manually add the InstallDir key. Probably in the wrong place (the config folder didn't exist but UE4 didn't care about it before I reset Windows so.. idk)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question