x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No collission unless simulate physics is turned on

I have worked for days on this to get it to work.

I have a Character with CapsuleComponent as root, and a MotionController with an attached BoxCollission.

These are the BoxCollission (Player) presets:

alt text

And these are the Character (Enemy) CapsuleComponent collission presets:

alt text

Player blocks Enemy, and Enemy blocks Player. Both are set up to generate hit events.

But this does not generate hit events at all. No events are fired on neither Player or Enemy - except for maybe once in a hundred collissions.

The only way to get the collissions to work is to enable 'Simulate Physics' on the Capsule/Enemy but that interferes with movement, and according to the documentation it should not be necessary to do so.

This has to be a bug? I have read that others have the same problem, but I have not seen an answer - I read that this was a known bug in 4.8 that has since been fixed - well, the bug is back...

I have tried to enable CCD and everything else I can think of, but nothing works.

Product Version: UE 4.11
Tags:
sim1.jpg (48.3 kB)
sim2.jpg (50.4 kB)
more ▼

asked Apr 30 '16 at 09:40 PM in Bug Reports

avatar image

dkoding
81 2 6 13

avatar image Sean L ♦♦ STAFF May 02 '16 at 02:33 PM

Hello,

I'd like to look into your specific setup. Could you please zip up your project, or a test project with the same setup and provide a link to Dropbox where I can download it? You can PM me a link on the forums: https://forums.unrealengine.com/member.php?160394-Sean-Flint

avatar image dkoding May 06 '16 at 02:41 PM

The problem still exists, but I got around it by using overlap events instead of hit events.

To recreate:

Create a vive character. Set up collisions as in the first image. (on a box used as a weapon) Create another character. Set up collisions as in the second image. (on the capsule)

When the capsule moves, I can hit it. When the capsule stands still, I can't. No hit events are fired. If I simulate physics on the capsule while it stands still, I can hit it just fine.

avatar image Sean L ♦♦ STAFF May 10 '16 at 05:34 PM

Hello,

I haven't been able to reproduce this issue on our end.

As a result, I'd like to look into your specific setup. Could you please zip up your project, or a test project with the same setup and provide a link to Dropbox where I can download it? You can PM me a link on the forums: https://forums.unrealengine.com/member.php?160394-Sean-Flint

avatar image alex-unrealUGSK Dec 23 '17 at 01:45 PM

bump..I have the same issue. Hit ( Blocking ) is working only if Simulate Physics is set to "on"

avatar image Sean L ♦♦ STAFF Jan 04 '18 at 12:52 PM

In my experience, it is better to use overlaps when working with characters, as hit events that are generated without the use of a physics simulation do not produce results that are as consistent as what you'd see using overlaps. It sounds like overlaps would be a better choice for what you're looking to set up.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered May 06 '16 at 02:36 PM

avatar image

Sean L ♦♦ STAFF
43.8k 485 152 440

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Well first off...if you wanted overlap events to works, you need Overlap collision and Generate Overlap Events checked. My collisions work just fine in 4.11 and have been since 4.6. I do not need to turn on Physics.

If you are wanting Hit Events to work with Blocking Collisions you need to enable Simulation Generates Hit Events, which you have, and then use the Event Hit node.

alt text

For more information on how collisions work in UE4, read this blog Collision Filtering Blog and then this doc Collision Overview Doc

Hopefully, between those two, you'll be able to handle collision much better. Good luck!

more ▼

answered May 01 '16 at 01:03 AM

avatar image

VictorBurgos
2.4k 60 27 111

avatar image dkoding May 01 '16 at 04:49 AM

Thank you for your comment. This is about hit events, not overlaps. I use blocking on both Enemy and Player, and I have checked Simulation generates hit events. OnComponentHit is just never called on either component unless I enable physics.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question