x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

materials not working on gear vr

Hi,

I have previously created gear VR apps from UE4 without problems, but using the same process I am now finding my materials are not working - in the app they are rendered as 'world grid material'.

I am applying baked lightmaps as emissive (unlit) materials. The meshes are created in sketchup and exported to blender where they are uv mapped and the textures baked. They have two uvmaps. They are imported to UE4 as FBX files, along with the lightmaps as PNG files, and the materials recreated there. I have tried this in both 4.10.4 and 4.11.2. The materials render fine in the editor. The test meshes are very small (38 tris).

Other materials in the standard 'first person template' are rendered fine in the app, but my meshes are not!

any ideas?

Product Version: UE 4.11
Tags:
more ▼

asked May 01 '16 at 10:32 AM in VR

avatar image

extropy
46 4 7 9

avatar image extropy May 01 '16 at 10:40 AM

some more info: Im using a Galaxy S6 running Android 6.0.1. and my PC is running windows 8.1 Pro

avatar image extropy May 01 '16 at 12:29 PM

Ive just re-apk'ed an old file from v.4.11.2 and it works fine so the implication is that its something to do with my meshes....

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

strangely, changing the MIP settings on the textures from 'fromTextureGroup' to 'NoMipMaps' has solved this problem...

the textures were not in a separate folder, which also seems to be significant.

any more comments welcome, thanks

more ▼

answered May 01 '16 at 07:52 PM

avatar image

extropy
46 4 7 9

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question