x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale

Had a couple of errors go off while running our integration tests. Thought perhaps these numbers may be useful to somebody. Haven't seen the visual results of this, but the build doesn't crash, it just causes our integration test to fail.

Wondering if it's possible we've done something wrong, or just that this edge case is not being handled well?

Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale
Error: SystemPositionForMacroUVs: {87478.187500, -81287.257813, 1705.693115}
Error: ObjectPostProjectionPositionWithW: {-293.613281, -84.152344, 10.000000, 0.007813}
Error: RightPostProjectionPosition: {-148.808594, -84.150391, 10.000000, 0.000000}
Error: UpPostProjectionPosition: {-293.609375, 173.273438, 10.000000, -0.007813}
Error: ObjectNDCPosition: {-37582.500000, -10771.500000}
Error: RightNDCPosX: -1.#INF00
Error: UpNDCPosY: -22179.000000
Error: MacroUVPosition: {87478.187500, -81287.257813, 1705.693115}
Error: MacroUVRadius: 200.000000
Error: DX: -1.#INF00
Error: DY: -11407.500000
Error: View0: {-0.948824, -0.315441, -0.015159, 1.000000}
Error: View1: {-0.068930, 0.160015, 0.984705, 1.000000}
Error: View2: {-0.308191, 0.935357, -0.173569, 1.000000}
Error: View3: {0.000000, 0.000000, 0.000000, 1.000000}
Error: ViewProj0: {-0.686864, -0.228676, -0.010921, 1.000000}
Error: ViewProj1: {-0.088836, 0.206307, 1.267383, 1.000000}
Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000}
Error: ViewProj3: {-0.308191, 0.935357, -0.173569, 1.000000

Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale
Error: SystemPositionForMacroUVs: {87615.867188, -81687.945313, 1703.777710}
Error: ObjectPostProjectionPositionWithW: {-303.000000, -86.011719, 10.000000, 0.000000}
Error: RightPostProjectionPosition: {-157.308594, -86.013672, 10.000000, 0.000000}
Error: UpPostProjectionPosition: {-303.003906, 172.994141, 10.000000, 0.007813}
Error: ObjectNDCPosition: {-30300000.000000, -8601172.000000}
Error: RightNDCPosX: -1.#INF00
Error: UpNDCPosY: 22143.250000
Error: MacroUVPosition: {87615.867188, -81687.945313, 1703.777710}
Error: MacroUVRadius: 200.000000
Error: DX: -1.#INF00
Error: DY: 2097152.000000
Error: View0: {-0.951876, -0.306114, -0.015062, 1.000000}
Error: View1: {-0.067936, 0.162816, 0.984315, 1.000000}
Error: View2: {-0.298860, 0.937969, -0.175776, 1.000000}
Error: View3: {0.000000, 0.000000, 0.000000, 1.000000}
Error: ViewProj0: {-0.693260, -0.223431, -0.010890, 1.000000}
Error: ViewProj1: {-0.087942, 0.210736, 1.274744, 1.000000}
Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000}
Error: ViewProj3: {-0.298860, 0.937969, -0.175776, 1.000000}

Product Version: UE 4.11
Tags:
more ▼

asked May 02 '16 at 11:57 PM in Bug Reports

avatar image

KeirBlackDelta
81 2 5 15

avatar image Matthew J May 03 '16 at 05:19 PM

Hello KeirBlackDelta,

What kind of integration testing are you running? It would be helpful to have more context on the situation to tell what is going on.

avatar image KeirBlackDelta May 09 '16 at 11:24 PM

Hi Matthew - I haven't investigated the exact cause or context as yet but it happens to us a couple of times a week during our integration tests which basically consists of AI-driven cars driving many laps around racing tracks.

As it looks to be a rare bug I thought I'd mention it as it looks as though Epic would like a repeatable test case and we have it occurring here fairly often.

It's not holding us back at the moment as we are able to comment out the error messages.

avatar image Matthew J May 12 '16 at 03:06 PM

I understand and I appreciate the report, but without any sort of reproduction steps, this wouldn't be helpful for solving the problem. We would need some sort of way to reproduce the issue ourselves so that we can take a look at the issue and attempt to fix it.

avatar image Konflict Apr 18 '18 at 04:51 PM

@KeirBlackDelta , by executing the r.EnableDebugSpam_GetObjectPositionAndScale 0 command you should be able to turn this thing off, and won't cause further issues in your tests.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

We haven't heard from you in a while, KeirBlackDelta. Are you still experiencing these issues? If so, could you provide the information I requested? We need more information from you to progress with this issue.

In the meantime I'll be marking this post as resolved for tracking purposes. Whenever you're available, please leave a comment and the post will reopen.

more ▼

answered May 09 '16 at 06:03 PM

avatar image xeoncat Aug 03 '17 at 08:05 PM

I had this error happen before but I was unable to determine what was causing it as I don't have any particle material using Macro UV's and it seemingly happened at random (but only when my pawn moved). If I had to guess it was in a PS with a Sphere spawn and a Killbox around it, that I had parented to my pawn's SpringArm to give the effect of space movement. I'm not sure what I did to make the error stop

Here is one of the outputs: LogParticles:Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale LogParticles:Error: SystemPositionForMacroUVs: {-2761.790039, -1107.707153, 2685.805664} LogParticles:Error: ObjectPostProjectionPositionWithW: {0.000000, -228.866699, 10.000000, 0.000122} LogParticles:Error: RightPostProjectionPosition: {238.350830, -228.866943, 10.000000, 0.000000} LogParticles:Error: UpPostProjectionPosition: {0.000000, 228.866699, 10.000000, -0.000122} LogParticles:Error: ObjectNDCPosition: {0.000000, -1874876.000000} LogParticles:Error: RightNDCPosX: inf LogParticles:Error: UpNDCPosY: -1874876.000000 LogParticles:Error: MacroUVPosition: {-2761.790039, -1107.707153, 2685.805664} LogParticles:Error: MacroUVRadius: 200.000000 LogParticles:Error: DX: 2097152.000000 LogParticles:Error: DY: 0.000000 LogParticles:Error: View0: {0.404583, 0.726425, 0.555535, 1.000000} LogParticles:Error: View1: {-0.352568, -0.436612, 0.827687, 1.000000} LogParticles:Error: View2: {0.843806, -0.530732, 0.079469, 1.000000} LogParticles:Error: View3: {0.000000, 0.000000, 0.000000, 1.000000} LogParticles:Error: ViewProj0: {0.482164, 0.865720, 0.662060, 1.000000} LogParticles:Error: ViewProj1: {-0.806911, -0.999259, 1.894301, 1.000000} LogParticles:Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000} LogParticles:Error: ViewProj3: {0.843806, -0.530732, 0.079469, 1.000000}

avatar image Spoondog Nov 21 '18 at 10:13 PM

Just started happening to me in the editor in 4.21, never seen it before and I have no idea what it's referring to as I haven't really added any new particles. Maybe not a problem as there is no crash. But I'll report back if it causes any more significant issues.

 LogParticles: Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale
 LogParticles: Error: SystemPositionForMacroUVs: {105663.742188, 112705.078125, -19.388561}
 LogParticles: Error: ObjectPostProjectionPositionWithW: {-124.714844, -527.625000, 10.000000, 0.000000}
 LogParticles: Error: RightPostProjectionPosition: {75.281250, -527.625000, 10.000000, 0.000000}
 LogParticles: Error: UpPostProjectionPosition: {-124.710938, -209.828125, 10.000000, 0.000000}
 LogParticles: Error: ObjectNDCPosition: {-12471484.000000, -52762500.000000}
 LogParticles: Error: RightNDCPosX: inf
 LogParticles: Error: UpNDCPosY: -inf
 LogParticles: Error: MacroUVPosition: {105663.742188, 112705.078125, -19.388561}
 LogParticles: Error: MacroUVRadius: 200.000000
 LogParticles: Error: DX: 2097152.000000
 LogParticles: Error: DY: -inf
 LogParticles: Error: View0: {0.867817, -0.496883, -0.000000, 1.000000}
 LogParticles: Error: View1: {-0.148571, -0.259484, 0.954251, 1.000000}
 LogParticles: Error: View2: {-0.474151, -0.828115, -0.299007, 1.000000}
 LogParticles: Error: View3: {0.000000, 0.000000, 0.000000, 1.000000}
 LogParticles: Error: ViewProj0: {0.867817, -0.496883, -0.000000, 1.000000}
 LogParticles: Error: ViewProj1: {-0.236076, -0.412313, 1.516281, 1.000000}
 LogParticles: Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000}
 LogParticles: Error: ViewProj3: {-0.474151, -0.828115, -0.299007, 1.000000}

...etc

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am getting the same thing in 4.15:

[tid=DE803B77][t=359.295197]LogParticles:Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale [tid=DE803B77][t=359.295197]LogParticles:Error: SystemPositionForMacroUVs: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectPostProjectionPositionWithW: {-607.687500, -5164.468750, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightPostProjectionPosition: {-439.859375, -5164.472656, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: UpPostProjectionPosition: {-607.656250, -4866.117188, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectNDCPosition: {-60768752.000000, -516446880.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightNDCPosX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: UpNDCPosY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVPosition: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVRadius: 200.000000 [tid=DE803B77][t=359.295197]LogParticles:Error: DX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: DY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: View0: {-0.964013, 0.157439, 0.214224, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View1: {0.234094, 0.120752, 0.964686, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View2: {0.126011, 0.980118, -0.153262, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View3: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj0: {-0.808903, 0.132107, 0.179755, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj1: {0.349206, 0.180130, 1.439054, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj3: {0.126011, 0.980118, -0.153262, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale [tid=DE803B77][t=359.295197]LogParticles:Error: SystemPositionForMacroUVs: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectPostProjectionPositionWithW: {-607.687500, -5164.468750, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightPostProjectionPosition: {-439.859375, -5164.472656, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: UpPostProjectionPosition: {-607.656250, -4866.117188, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectNDCPosition: {-60768752.000000, -516446880.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightNDCPosX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: UpNDCPosY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVPosition: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVRadius: 200.000000 [tid=DE803B77][t=359.295197]LogParticles:Error: DX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: DY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: View0: {-0.964013, 0.157439, 0.214224, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View1: {0.234094, 0.120752, 0.964686, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View2: {0.126011, 0.980118, -0.153262, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View3: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj0: {-0.808903, 0.132107, 0.179755, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj1: {0.349206, 0.180130, 1.439054, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj3: {0.126011, 0.980118, -0.153262, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale [tid=DE803B77][t=359.295197]LogParticles:Error: SystemPositionForMacroUVs: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectPostProjectionPositionWithW: {-607.687500, -5164.468750, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightPostProjectionPosition: {-439.859375, -5164.472656, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: UpPostProjectionPosition: {-607.656250, -4866.117188, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectNDCPosition: {-60768752.000000, -516446880.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightNDCPosX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: UpNDCPosY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVPosition: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVRadius: 200.000000 [tid=DE803B77][t=359.295197]LogParticles:Error: DX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: DY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: View0: {-0.964013, 0.157439, 0.214224, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View1: {0.234094, 0.120752, 0.964686, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View2: {0.126011, 0.980118, -0.153262, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View3: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj0: {-0.808903, 0.132107, 0.179755, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj1: {0.349206, 0.180130, 1.439054, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj3: {0.126011, 0.980118, -0.153262, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale [tid=DE803B77][t=359.295197]LogParticles:Error: SystemPositionForMacroUVs: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectPostProjectionPositionWithW: {-607.687500, -5164.468750, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightPostProjectionPosition: {-439.859375, -5164.472656, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: UpPostProjectionPosition: {-607.656250, -4866.117188, 10.000000, 0.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ObjectNDCPosition: {-60768752.000000, -516446880.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: RightNDCPosX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: UpNDCPosY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVPosition: {207325.828125, -422379.500000, -44242.515625} [tid=DE803B77][t=359.295197]LogParticles:Error: MacroUVRadius: 200.000000 [tid=DE803B77][t=359.295197]LogParticles:Error: DX: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: DY: -inf [tid=DE803B77][t=359.295197]LogParticles:Error: View0: {-0.964013, 0.157439, 0.214224, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View1: {0.234094, 0.120752, 0.964686, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View2: {0.126011, 0.980118, -0.153262, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: View3: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj0: {-0.808903, 0.132107, 0.179755, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj1: {0.349206, 0.180130, 1.439054, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000} [tid=DE803B77][t=359.295197]LogParticles:Error: ViewProj3: {0.126011, 0.980118, -0.153262, 1.000000}

more ▼

answered Dec 07 '17 at 02:03 PM

avatar image

Phil Rowe
76 1 2 8

avatar image Matthew J Dec 08 '17 at 09:47 PM

Hello Phil,

As I mentioned in my other posts to the original poster, without steps or information on how to reproduce this issue, I will not be able to continue investigating this issue. I would also suggest trying to make a copy of your project and upgrade it to a newer version of the engine to see if the issue is resolved.

avatar image Konflict Apr 18 '18 at 04:50 PM

Dear Matthew,

https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Source/Runtime/Engine/Private/Particles/ParticleSystemRender.cpp#L7008

This is a hard to reproduce issue - by Epic standards as well - and the error is printed to provide you / us with more informations regarding why the values of DX and DY may become invalid after the computations. In all three reports you can clearly see the Right /o Up PPPos w will be 0, which results in an invalid matrix operation, and this is as long as i can understand what is triggering the error. Beyond that, an engineer involved in the implementation of this math should take a look at the values. Please forward these error reports to the assigned person who will investigate it further.

The error message is implemented for this very reason, and is enabled by default which is triggering malfunctions in the tests the OP was conduncting, which means it should be disabled by default. As for this, i'd suggest an another issue tracker record can be put in, so the value will be disabled for next versions.

It's been there since 4.10 and most likely spamming the logs for everybody with these scary red messages provides no informations for us regular beings what is causing it actually.

avatar image rit Aug 07 '18 at 02:26 AM

I'm using 4.16.3 and having the same problem, but it is hard to reproduce the bug...please help

LogParticles:Error: Bad values in FParticleSystemSceneProxy::GetObjectPositionAndScale LogParticles:Error: SystemPositionForMacroUVs: {-288488.062500, 94269.554688, -822.198792} LogParticles:Error: ObjectPostProjectionPositionWithW: {-327.019531, -413.882813, 10.000000, -0.031250} LogParticles:Error: RightPostProjectionPosition: {-143.750000, -413.882813, 10.000000, 0.000000} LogParticles:Error: UpPostProjectionPosition: {-327.023438, -42.882813, 10.000000, 0.000000} LogParticles:Error: ObjectNDCPosition: {-32701954.000000, -41388280.000000} LogParticles:Error: RightNDCPosX: -inf LogParticles:Error: UpNDCPosY: -inf LogParticles:Error: MacroUVPosition: {-288488.062500, 94269.554688, -822.198792} LogParticles:Error: MacroUVRadius: 200.000000 LogParticles:Error: DX: -inf LogParticles:Error: DY: -inf LogParticles:Error: View0: {-0.149925, -0.988697, 0.000000, 1.000000} LogParticles:Error: View1: {-0.169382, 0.025685, 0.985216, 1.000000} LogParticles:Error: View2: {-0.974080, 0.147709, -0.171318, 1.000000} LogParticles:Error: View3: {0.000000, 0.000000, 0.000000, 1.000000} LogParticles:Error: ViewProj0: {-0.137381, -0.905974, 0.000000, 1.000000} LogParticles:Error: ViewProj1: {-0.314205, 0.047646, 1.827587, 1.000000} LogParticles:Error: ViewProj2: {0.000000, 0.000000, 0.000000, 1.000000} LogParticles:Error: ViewProj3: {-0.974080, 0.147709, -0.171318, 1.000000}

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is not a bug. There is a particle outside the level boundaries " {-288488.062500, 94269.554688, -822.198792}". You need to get it inside the level grid.

more ▼

answered Nov 24 '18 at 10:28 AM

avatar image

Qukla
59 3 5 11

avatar image Konflict Dec 01 '18 at 02:55 PM

Disinformation, but why?

Reasoning in the follows: https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Source/Runtime/Engine/Private/Particles/ParticleSystemRender.cpp#L7103

The console command's help will explain the functionality. "Enables or disables debug log spam for a bug in" It is a bug, epic did recognize the issue.

https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Source/Runtime/Engine/Private/Particles/ParticleSystemRender.cpp#L7153

The validation is put there to investigate the bug. It is enabled by default, which is causing the error showing up. Appears to be safe to ignore, and once you set the console command it won't spam your logs anymore. It should actually be disabled by default, but it's not.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question