x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

BSP Brush: Where is the property panel for applying materials?

Hello!

I would like to apply a material to any BSP Brush, but the property for it in the details panel never shows up!

Using the Mode tab I dragged a BSP Box inside my level, switched to the Geometry Tab, clicked on a face of this brush but within the details panel there is no option to apply a material - as it should be according to the tutorial.

I can do everything else with the geometry, like change the shape of the cube, playing with it's edges and faces. As you can see on the screenshot, there are only these three categories but not the ones for the materials and stuff.

Any idea?

alt text

Product Version: UE 4.11
Tags:
question01.jpg (174.8 kB)
more ▼

asked May 03 '16 at 04:01 AM in Bug Reports

avatar image

ProMazeus
1 1 2 3

avatar image Adam Davis STAFF May 03 '16 at 07:32 PM

Hi ProMazeus,

It should be under your Surface Materials and Geometry tabs in the details pane as seen below:

alt text

You can also drag a material directly onto the specific surfaces you are attempting to edit.

Try dragging in a new BSP and selecting it, do you see these options available to you?

bspmat.png (272.1 kB)
avatar image ProMazeus May 03 '16 at 09:45 PM

Hey Adam! Thank you for the reply! See, this is the point. I do not have any more options like the three I mentioned above. There is no "Surface Materials" option below the others!

Why is that? I'm literally out of options. ^^

avatar image ProMazeus May 03 '16 at 09:55 PM

By the way, directly attaching a material to a brush doesn't work either.

avatar image ProMazeus May 04 '16 at 04:47 PM

Here's another screenshot.

alt text

avatar image Adam Davis STAFF May 04 '16 at 06:35 PM

Try verifying your engine build. To do so, go to the Launcher>library>engine version dropdown context menu>verify. This will check to see if any of your engine files are damaged or missing and repair/replace them if they are.

avatar image ProMazeus May 04 '16 at 09:48 PM

I verified the engine build. After that I opened my project in the verified version, but nothing changed... This is still all what I get from the details panel:

alt text

avatar image Yun Yun May 05 '16 at 07:34 AM

Hi, ProMazeus. I had the same trouble. Here's how I fixed it. Do NOT click a brush in World Outliner, but left-click one face of the brush at viewport. The details panel of the brush has only three tabs, but with one face selected, you see "Geometry" tab, at which choose Select > Select Matching Brush, then at "Surface Materials" tab you choose the material to apply on the whole brush.

avatar image ProMazeus May 05 '16 at 04:47 PM

Hey guys!

I finally found out what the problem is. It is a stupid one. I tried to produce BSPs everywhere else in my level. And it turned out that I finally could texture my brushes on some points of my level.

The issue is, that you cannot build a BSP while you are in another existing BSP in your level. What I did early in the beginning of my project, was to set a huge Box-Brush inside my level to define the size of the level. And now I realized that you can't build brushes from the inside of this Box-Brush but you can when outside, of course.

I didn't know that and somehow don't understand it, but... THE PROBLEM IS FIXED.

(There could be a warning at least to prevent designers from having such situations.)

Sorry guys, all my bad. I really appreciated all the help and I am very grateful. Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm happy to hear you found a solution to the error you were experiencing. I am marking this as answered for tracking purposes.

more ▼

answered May 05 '16 at 04:51 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question