x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Player locked after ClientTravel \ Open Level

Hi guys. I'm creating my FPS game, and i got a problem, but first i want to describe my project's architecture for better undestanding what is happening. I have two maps in my project:

  1. Entry - in this map i've created main menu, and three c++ classes: MenuCharacter, MenuPlayerController, MenuGamemod. Code of this classes is the same as they were by default.

  2. Test - in that map i have BaseCharacter, BasePlayerController and BaseGamemode.

So, the problem: When i'm starting my game, loaded Entry level with main menu. When i'm doing ClientTravel( ip, TRAVEL_Absolute) on my dedicated server with running "Test" map, or when i'm doing Open Level via blueprint, i appear in "Test" level, but i can't moving, jumping or crouching. I can do anything. But when i open "Test" level in editor and press "Play" button in editor i can move, jump etc. Well, guys, i don't know where problem can be, but I think, I'm doing something in wrong way (or not doing...) when traveling from one world to another. I've checked that my classes are created well, checked that they constructors and "SetupPlayerInputComponent" called. But i still cant move. Help me please.

Here settings of "Entry" map: alt text

Here settings of "Test" map: alt text

Product Version: UE 4.11
Tags:
more ▼

asked May 03 '16 at 05:09 PM in C++ Programming

avatar image

Effrenatus
6 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Suddenly, problem was solved by myself. In my Main menu i've forgotten to hide menus before Travel\Open Level and return back PlayerController->SetInputMode() values.

more ▼

answered May 03 '16 at 07:30 PM

avatar image

Effrenatus
6 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question