x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Swarm failed to kick off

I'm trying to build lighting in my project, but Swarm keeps failing to be "kicked off". I've tried the solutions in some other threads on here regarding rebuilding unrealLightmass, but it didn't help.

What I tried specifically is I downloaded Unreal source from GitHub (v 4.11.2), built the entire engine from scratch, and opened my project in that version of the engine (which was the same exact version as the one I had been using, just not built from source) and I got the same error with Swarm when trying to build the lighting.

Any ideas on how else to fix this?

Product Version: UE 4.11
Tags:
more ▼

asked May 04 '16 at 10:12 PM in Using UE4

avatar image

janimationd
422 20 95 122

avatar image janimationd May 06 '16 at 06:09 PM

Here's my Swarm log: http://pastebin.com/raw/QahfJK8v

I'm not sure why it's failing to open that mtrlgz file. If I delete all the ones in that folder, and run Swarm again, it creates these 15 files once more: alt text

... then gets the same error. I thought it might be failing to open them because my antivirus was trying to scan them or something, but even temporarily disabling my antivirus didn't help.

capture.png (66.7 kB)
avatar image jblaswu May 27 '16 at 06:39 PM

what engine are you using? source or release build? could you post the log of the building process?

avatar image janimationd May 27 '16 at 06:49 PM

I was trying to build in 4.11 in a project I had upgraded from 4.10. My log is posted in my other comment: http://pastebin.com/raw/QahfJK8v.

I'm not sure what you mean by source or release, I was building lighting only out of the editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So turns out this is due to upgrading a 4.10 project to 4.11.

I have an old version of this project in 4.10, and the lighting builds fine. I just tried upgrading the 4.10 version of the project to 4.11 again, and the lighting build failed on that copy of the project with no other changes.

Sounds like a bug report in the making.

more ▼

answered May 11 '16 at 06:33 PM

avatar image

janimationd
422 20 95 122

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question