x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Having troubles getting leaderboards to come up on Android

Trying to finish up the Android version of our game. Game is currently published as a Beta release on the play store. In-app purchases are working but I cannot get the leaderboards to show up. When I look my game up in the Google Play Games app it doesn't list any achievements. I have all kinds of achievements and leaderboards set up on the google dev console, Enagle Google Play Support turned on for my project, the leaderboard and achievement map settings done, but there's still something I'm missing. Shouldn't I be able to call this while in Beta? Is there a step I have missed somewhere, like some secret code I needed to add to my DefaultEngine.ini like I needed to do to get in-app purchases to work?

Product Version: UE 4.11
Tags:
more ▼

asked May 07 '16 at 04:32 AM in Blueprint Scripting

avatar image

Spectral Ink
219 10 12 23

avatar image Samantha Sutton ♦♦ STAFF May 12 '16 at 07:04 PM

Hey Spectral Ink,

Please review our documentation that we have on Android Leadership Boards. Once you've gone through that material and have fixed what you're able to, go ahead and test your leadership board again.

If that does not work for you, please provide me with your Android device logs:

  • Attach your phone to the computer

  • Go here: C:\NVPACK\android-sdk-windows\tools

  • Open up Monitor.bat

  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86

  • Open up Monitor.exe

  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they're highlighted.

Thank you!

avatar image Spectral Ink May 13 '16 at 12:58 AM

Thanks for getting back to me. Yes I've done all the set-up on the Unreal side. I'm trying to get Google to reply to see if I have everything on the Google side set up correctly.

Cannot get the monitor to launch. It seems like the Eclipse tools won't install if I only have Visual 2015 Community installed.

avatar image Samantha Sutton ♦♦ STAFF May 13 '16 at 04:37 PM

Hey,

VS2015 works for UE 4.10 and up. Community shouldn't have any trouble, only Express seems to. Do you have AndroidWorks installed too?

Let me know once you hear back from Google. If you resolve your issue in the meantime, could you please disclose that information here?

avatar image Spectral Ink May 13 '16 at 11:28 PM

Most of Android works are installed, but a small section won't install because it cannot find VS2015. Unreal works fine with Community (I've done some plug-in dev, worked great) but some of the AndroidWorks doesn't.

avatar image Samantha Sutton ♦♦ STAFF May 16 '16 at 02:36 PM

Did you install AndroidWorks and Visual Studio on different hard drives?

avatar image Spectral Ink May 16 '16 at 03:17 PM

Thier both on my Dave drive. I have one of those solid state drives for my c drive and it fills up fast so I try to install as many programs on the door drive as possible. But my last computer was all on the character drive and same issue. There's a part of the Android tools that won't install without vs and it doesn't like Community apparently.

avatar image Samantha Sutton ♦♦ STAFF May 17 '16 at 05:34 PM

Hey Spectral Ink,

Looking on the Nvidia site, I found this forum post. It says that with the next Nsight Tegra release, Visual Studio 2015 would be supported. That was back in 2015, so I believe that's already been released.

Have you tried uninstalling and reinstalling your AndroidWorks?

Here is the documentation link for setting up Visual Studio for UE4.

Eclipse should not matter whether or not it's being installed by the way. Eclipse is not supported by UE4. We also suggest installing this on your C drive. I have my AndroidWorks installed on my SSD C drive as well, without any difficulties. My engines are installed on my larger non SSD drive.

Thanks!

avatar image Spectral Ink May 18 '16 at 05:34 PM

Google wrote back to me saying the reason the leaderboards don't come up is because it hasn't recorded enough scores to be activated. Now how I'm supposed to know I've coded it up correctly on my end so I'm sending scores to Google in the first place, Google has no answer for. As a developer I have a few choice words for that obvious design flaw that I'll leave to your imagination, but they said as far as the Google side of the equation everything is set up properly.

avatar image Samantha Sutton ♦♦ STAFF May 19 '16 at 03:10 PM

Are you or anyone else on your team able to play your game until you've received enough scores to see if your leadership board is working? If you followed our guild on Leadership boards for Unreal Match 3, your board should be working properly.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Spectral Ink,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered May 23 '16 at 03:49 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question