x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HTC Vive HMD and Controller tracking issues

There is a disconnect between headset/controller tracking and game engine values.

When you read the location of the controller or headset in the gameworld the values you get don't correspond with what is rendered.

For example, the location of the controller is rendered correctly. But when doing a line trace from the controller it is trailing the controller.

Watch this video for a more in depth view of the problem: https://www.youtube.com/watch?v=FCDCvbo_ClM&feature=youtu.be

Product Version: UE 4.12 Preview
Tags:
more ▼

asked May 07 '16 at 10:40 AM in Bug Reports

avatar image

Rasped
58 9 11 13

avatar image Rudy Q ♦♦ STAFF May 09 '16 at 07:15 PM

Hello Rasped,

I noticed that you were experiencing some panning when in VR. This may be due to Use pawn control rotation being checked to true. Could you try going into your camera and making sure that this is turned off. I have a few questions concerning the issue with the controller that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue in a clean project?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

avatar image Rasped May 10 '16 at 11:07 AM

I have made a new video here: https://www.youtube.com/watch?v=CoKg11L71X4

It also happens in a new project. I just demonstrate in this project because I had the controllers set up as well.

The floatiness happens on a default pawn when you add a camera. Nothing more to it.

avatar image muchcharles May 13 '16 at 01:47 PM

Some of that is expected: if you attach a laser mesh as a component to the controller with low latency update on it should be fine, if you do anything to make an object or debug primitive programatically follow it through position updates in blueprints or C++, it won't, because you aren't working with the low latency late-updated coordinates. Are you actually attaching the laser (I didn't see it in the component tree view when you went to blueprints in the video, and you mentioned a line trace, so I'm assuming that's what you are doing)?

The chaperone bounds thing looks bad though; can you try turning off interleaved reprojection and see if you still see it? I saw it with one update in a 4.11 preview really bad, but haven't seen it as bad lately.

avatar image Rudy Q ♦♦ STAFF May 17 '16 at 06:12 PM

Hello Rasped,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

avatar image Stephan.Menzel Feb 03 '17 at 12:06 PM

It seems to me this is not fixed. I have seen this since I started developing with the Vive and always considered it my fault. But whatever I do, I cannot stop the chaperone from floating around and the resulting tracking inconsistencies seem increase over time, rendering the tracked objects (such as Motion Controllers) almost unusable.

Is there a fix for this or a suggestion as to what I can try? Use pawn control rotation on/off seems to have no effect on this.

Cheers, Stephan

avatar image Rudy Q ♦♦ STAFF Feb 03 '17 at 03:16 PM

Hello Stephan.Menzel,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue in a clean project?

  3. Could you provide screen shots of any blueprints/settigns that may be involved with this issue?

avatar image MrMoose2342 Feb 20 '17 at 12:10 PM

Hello Rudy, thanks for your response. Sadly I could not provide a clean standalone test due to lack of time. We have the issue under control though. See my comment to ReaperGrim94

avatar image Stephan.Menzel Feb 03 '17 at 12:03 PM

I am having the same problem with a C++ project in 4.14.3.

It looks precisely as in the video and manifests much the same way. Is there any update on this?

Cheers, Stephan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Rasped,

I was able to reproduce this issue on our end. I have written up a report ( UE-30534) and I have submitted to the developers for further consideration. I will provide updates with any pertinent information as it become available. As for the controller issue, would it be possible for you to provide a sample project that reproduces this issue so that I could take a closer look?

more ▼

answered May 10 '16 at 03:33 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

avatar image ReaperGrim94 Feb 20 '17 at 12:09 PM

Has this been resolved, I seem to still get this issue on 4.12 and 4.15 or is there something I have to do to fix it.

Cheers.

avatar image Stephan.Menzel Feb 20 '17 at 12:16 PM

Try attaching your motion controllers and camera component to an unmoving origin scene component. I don't know if this has been fixed as I still see my chaperone floating but it doesn't seem to be affecting the tracking itself when set up correctly.

avatar image Rudy Q ♦♦ STAFF Feb 20 '17 at 01:40 PM

Hello ReaperGrim94,

I have provided a link to the public tracker. Please feel free to use the link provided for future updates. However, I am seeing that the issue reported here was resolved in 4.13. Could you provided a set of steps to reproduce this issue in a clean project in the latest version of the engine?

Link: https://issues.unrealengine.com/issue/UE-30534

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question