x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Movie not playing in Gear VR

My movie or media will play in editor but never when packaged.

Here are my steps. I am using 4.10.4 I am getting this problem with a brand new project.

  1. Make a brand new project.

  2. Create a folder in Content called "Movies" with this exact spelling.

  3. Right click inside the Movies file and select Import. I imported my movie file.

  4. Right click the movie. Set Playback Rate to 1.0 and change the File or URL to a relative path instead of absolute. I changed mine from C:/Unreal/Content/Movies/360movie_sample.mov to ./Movies/360movie_sample2.mov

  5. Right click the movie to make a media texture.

  6. Right click the media texture to make a media material.

  7. Double click the material and open the material editor. Change the material settings from DefaultLit to Unlit. Connect the top pin from the texture sample to Emissive Color

  8. Configure the project for Gear VR.

  9. Package Project -> Android -> ETC2

I send the build over and then I opened the file. The scene is black except for the 2 virtual pads.

alt text

Here is my Android Settings Screen. alt text

I would be willing to share this project with @UnrealStaff privately but I do not wish to make the video public. Thank you.

Product Version: UE 4.10
Tags:
more ▼

asked May 09 '16 at 11:09 AM in Packaging & Deployment

avatar image

so2gamemake
73 5 9 14

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Notice that Gear VR is an Android system. Movies that play on Windows / MAC could not play on Android, and vice versa. Please check that your media files follow the Android guidelines for supported media formats: http://developer.android.com/guide/appendix/media-formats.html

Also, I had some minor issues with UE 4.10 playing movies on Gear VR. I suggest you to upgrade to 4.11 ;)

more ▼

answered May 09 '16 at 11:21 AM

avatar image

ocramot
200 16 15 23

avatar image so2gamemake May 10 '16 at 02:06 AM

Thank you very much for the reply! It looks like .mov is not on that list. I have downloaded 4.11 and there is no Assets folder in Java for signature files. Did you copy your folder from 4.10 there or is there a new procedure?

avatar image ocramot May 10 '16 at 07:12 AM

Are you talking about the .osig files? Honestly I don't remember if it was done automatically, but I think you can just copy-paste from [Epic Games installation directory]\4.10\Engine\Build\Android\Java\assets to [Epic Games installation directory]\4.11\Engine\Build\Android\Java\assets and you'll be fine.

avatar image so2gamemake May 10 '16 at 07:14 AM

That worked! Thank you very much. Cheers!

I'm still working on the video. I downloaded a few MP4 videos that play on Android media player on the device just fine but both 4.10 and 4.11 won't play the files at all. Windows plays the file OK. VERY big headache.

avatar image ocramot May 10 '16 at 07:48 AM

Happens to me all the time. mp4 won't play in the editor but it will play in the game, so I'll be satisfied (right? :D )

avatar image so2gamemake May 11 '16 at 02:00 AM

I haven't had that issue just yet. I've had MP4s that play in Android media player but they won't play in editor or game.

Would you be willing to share what the movie looks like in the content browser if UE4 will not play in windows but will in Gear?

I had a video say "Not Ready" and the play rate was forced at 0.0 I could not change to 1.0 Connect to event begin play and play the media didn't work either.

avatar image ocramot May 11 '16 at 06:50 AM

I just force the play via blueprint at start. In the Gear VR, it works; in the viewport, I see a black screen.

avatar image so2gamemake May 11 '16 at 08:44 AM

Kind of scary but if it works, it works! I just don't like wasting time building and sending to the device.

avatar image so2gamemake Jul 26 '16 at 02:14 AM

Sorry if this seems old but what resolutions of video did you get to play successfully in GearVR?

avatar image haruna Jul 27 '16 at 09:29 AM

Use anything 16:9

avatar image ocramot Jul 27 '16 at 08:34 PM

If you look at the link I provided in the first post, the available resolutions are listed in tables 2 and 3, at the bottom.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question