x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Help! Some textures going blurry, also packaged level will not open

I am a student studying CGI and making my first game level. I have been a little ambitious with my map size (around a Km squared) and therefore believe that the problem might be that my texture streaming pool (which is showing up top left in red when simulating the game) is causing textures to go to some primitive form. I learned later on in the project that textures should all be square which I believe could cause problems with LOD's. I am using the kite demo for my foliage which is quite resource heavy too.

I have packaged my level as a test and found that when I go to play it I get an error message along the lines of level has not been cooked (will leave screenshot as an attachment).

Any quick response would be greatly appreciated as asking a forum such as this helps improve my overall mark for the unit. alt text alt text

Many thanks, Sam

Product Version: Not Selected
Tags:
build level.jpg (747.3 kB)
more ▼

asked May 11 '16 at 03:26 AM in Using UE4

avatar image

samrichards
1 1 2 4

avatar image Wallenstein May 11 '16 at 04:34 AM

Try in the editor "Settings" and then "Engine Scalability Settings". It may be that your machine is recognized by UE as too slow depending on what you have in the scene and then the textures will be reduced to maintain speed. You can override the behavior there

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Try cooking your content. Go into your project folder and open the Default Editor.ini in the Config folder. Add this:

[AlwaysCookMaps]

+Map=/Game/Folder your map is in/Map name

Add however many maps is needed for your project.

more ▼

answered May 11 '16 at 07:49 AM

avatar image

A7426764001
95 3 11 12

avatar image AndrewHurley May 11 '16 at 02:23 PM

Hey samrichards,

Be sure you have Texture Streaming enabled as well as trying to two suggested resolutions as provided by the users above.

Since you are somewhat new to the UE4 community and the game design process in general, I highly suggest taking a look at our documentation which covers how to troubleshoot texture streaming issues like this. It goes into a bit of high level explanation, but if you read it you can figure out how to start troubleshooting.

Texture Streaming Documentation

If you have further questions or need additional assistance, please let me know.

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thanks for all the help guys!
For first suggestion, I have tried lowering the settings to no avail. The PCs at uni are much better than my home one yet the problem persists there. My texture streaming pool is often over 300mb more than it should be so I probably need to lower some of my textures.

I have tried cooking my level and then packaging it only to get the same error message. I will try adding the code into the editor next. Will also be sure to fully read the documentation, thanks Andrew.

more ▼

answered May 11 '16 at 02:57 PM

avatar image

samrichards
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question