x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Seamless Travel leaves clients unresponsive

Hi,

in our project we encountered the following problem: when doing a Seamless Travel from the lobby scene to the game scene, all remote clients remain unresponsive until the server send them back to the pre-lobby scene (disconnecting them). If we do not use a seamless travel, everything works as expected.

In attachment you can find a simple test case where you can see the unexpected behavior:

  1. clients load a local, offline map ("ClientMap");

  2. server runs a lobby map ("ServerMap1" with ServerMap1GameMode);

  3. when a client logins, after few seconds the server travels to map "ServerMap2" (in ServerMap1GameMode ctor you can control if using a Seamless Travel or not changing bUseSeamlessTravel);

  4. when in "ServerMap2", after few seconds ServerMap2GameMode will disconnect all the clients (sending them back to their offline map "ClientMap" - step 1) and the server will re-load "ServerMap1" (step 2).

If you run the above sample with bUseSeamlessTravel set to true (in ServerMap1GameMode ctor), when in "ServerMap2" clients will become unresponsive until the server disconnect them; then they will return interactive. If bUseSeamlessTravel in ServerMap1GameMode is set to false, everything works as expected, and clients in "ServerMap2" will work as usual.

The ZIP file contains two BAT files to run a client and a server (you can spawn multiple clients if needed). Note that, to use them, you must update the paths hard-coded in the BAT files.

Product Version: UE 4.11
Tags:
more ▼

asked May 11 '16 at 05:43 PM in Bug Reports

avatar image

Kafumanto
217 16 22 29

avatar image Nuy_exe Jun 06 '16 at 01:00 AM

It seems like this bug was not fixed in 4.12 version as well. I need to persist some data in PlayterState, so I need to perform a seamless travel, however, as you described, when set bUseSeamlessTravel to true in the GameMode the host travels, clients still find sessions but can't join. When I set bUseSeamlessTravel to false they do join session as usual but as expected PlayerState is lost.

avatar image Rudy Q ♦♦ STAFF Jun 06 '16 at 01:06 PM

Hello andreybicalho,

After taking another look at the report for this issue, the status for this issue has been updated to fixed. This means that you may be experiencing a similar but different issue. Could you create a new thread for tracking purposes and provide a link to it in a reply here?

avatar image Nuy_exe Jun 26 '16 at 02:26 PM

I think that's not necessary... maybe I misunderstood something about it... I setup a new map for a lobby and then it worked.

In previous scenario:

  • 1 - players start at the menu map

  • 2 - Then I was trying to perform a seamless travel without had previously joined the session

now:

  • 1 - players start at the menu map

  • 2 - players find session and join it by doing a "hard travel" (bUseSeamlessTravel set to false) to that lobby map

  • 3 - now the host can perform a seamless travel to whatever map I want and the playerstate data I selected in CopyProperties function is persist across maps

Thank you for the reply anyway.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Kafu,

After running a few tests on the project provided I was able to find that this issue appears to be a known issue (UE-18413) and that it has been submitted to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered May 12 '16 at 03:32 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question