x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

unresolved EmptyLinkFunctionForGeneratedCode

I've created a separate module within my game project and it's been working fine for building and running in the editor on Win64. It's even built and packaged properly on iOS, however when I try and package the project for Win64 or Android I'm getting a linker error:

UnrealBuildTool: UELinkerFixups.cpp.obj : error LNK2019: unresolved external symbol "void __cdecl EmptyLinkFunctionForGeneratedCodeMyModuleName(void)" (?EmptyLinkFunctionForGeneratedCodeMyModuleName@@YAXXZ) referenced in function "void __cdecl UELinkerFixups(void)" (?UELinkerFixups@@YAXXZ)

I'm unsure what setup I have that is incorrect. I see that the build process should probably be generating a generated.cpp for my module inside the Intermediate directory, but I don't see one for my module. Does anyone know what my problem could be?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked May 12 '16 at 01:35 AM in C++ Programming

avatar image

NeoRob.gg
66 1 5 12

avatar image Matthew J May 12 '16 at 03:58 PM

Hello NeoRob.gg,

What version of the editor are you using? Also, could you provide the entire log file from when your packaging fails? This can be found in your project's directory under Saved > Logs. There could be some other messages that point toward what the issue is.

avatar image NeoRob.gg May 12 '16 at 11:18 PM

I'm using a source build based on 4.10 I'm looking at the log and it doesn't really help narrow anything down. There are no other errors, just the linking errors due to that module's autogenerated function.

Should every module get a .generated.cpp file? Could there be something not correct with my .Build.cs, Target.cs or .uproject file?

avatar image Matthew J May 13 '16 at 01:19 PM

I cannot be sure without knowing more information. Even if you can't find anything, the logs could still be helpful, as any information is at this point. Have you tried following the guidelines laid out here?

UHT should generate a generated .h but I'm not sure about a .cpp.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

We haven't heard from you in a while, NeoRob.gg. Are you still experiencing this issue? If so, have you tried checking what I mentioned in my previous comment? In the meantime, I'll be marking this issue as resolved for tracking purposes. Whenever you're available, please leave a comment and the question will reopen.

more ▼

answered May 19 '16 at 03:24 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I meet same issue after upgrade from 4.11.2 to 4.12.3. Just clean and build again in visual studio, it works.

more ▼

answered Jun 20 '16 at 08:16 AM

avatar image

xpolife
11 1 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question