x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Scaling a skeletal mesh with capsule shadows breaks the shadows

Scaling skeletal mesh with capsule shadows breaks the shadows.

I can recreate it with any skeletal mesh I've tried.

The quickest way to test it would be:

  1. Use the ThirdPersonExampleMap

  2. Place a SK_Mannequin in the scene separate from the player.

  3. Hook up the shadow physics asset with the existing physics asset.

  4. Enable capsule direct shadows / capsule indirect shadows on the placed SK_Mannequin

  5. Scale the character to 2x and back to 1x and compare the shadows.

alt text

Also, I've also had some issues with a few meshes where capsule shadows not matching up with how the physics asset looks, it might be related? Is there a way to preview the physics asset in the viewport?

Product Version: UE 4.11
Tags:
ew.jpg (86.1 kB)
more ▼

asked May 12 '16 at 05:02 AM in Rendering

avatar image

ZacD
3 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

This behavior is expected. Using the default physics asset for your Capsule Shadows is not recommended, as you will definitely not see the best results. Also, scaling the skeletal meshes is not advised. This is because it is using a Tiled Deferred Culling method to break down the capsule shadows for only what needs to be rendered. When you scale the mesh up, it is easier to see the tiles. See this video for more information regarding Tiled Deferred Culling: https://youtu.be/22jvxFoTHBk?t=27m13s

What you can try to do is play around with the console variables, which will allow you to alter the capsule settings and potentially see better results. You can find more information about this method here: http://timhobsonue4.snappages.com/lighting-capsule-shadows

Finally, another method you can try is to create a brand new physics asset from scratch. The Physics Asset uses the capsules as a way to generate cheap shadows off of them. What you can do is create a new one with fewer capsules and manually assign this to the skeletal mesh.

Let me know if you have any further questions.

Have a great day

more ▼

answered May 12 '16 at 02:45 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 441

avatar image ZacD May 12 '16 at 03:01 PM

Thanks, I just wanted to make sure the behavior was expected. Sometimes scaling is useful, but I definitely understand if I have to make a compromise there.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question