x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Animation bugs?

Has anyone else found that when keyframing parameters like "Position" and "Shear" they seem to add unwanted movement in the tween between the frames? For example in the Position animation it would move halfway to the second keyframe then sort of bounce backwards and then continue moving to the second keyframe. Please help it's been bothering me with a project i'm trying to setup. (The widget component I was trying to animate was text)

Product Version: UE 4.11
Tags:
more ▼

asked May 12 '16 at 10:29 PM in Bug Reports

avatar image

ElSnaps.
31 2 8 10

avatar image Rudy Q ♦♦ STAFF May 13 '16 at 01:47 PM

Hello Sunshinewebsie,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. Could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints and/or widgets involved?

avatar image ElSnaps. May 14 '16 at 06:11 PM

Ok, I have managed to replicate this bug so it's either an issue with my UE4 or everyones. To replicate it:

  • Create a new Blank Code Project (C++)

  • Create a new User Widget Blueprint

  • Create a Gamemode Blueprint

  • Create a Player Controller Blueprint

  • Setup the Gamemode to use the Player Controller

  • Setup the Project to use the created Gamemode

  • Inside the Player Controller on begin play create widget and add to viewport

  • Inside the Widget Create a Text Component and anchor it to center

  • Create a new animation for this Text Component

  • Set the X position of the Text component to be -750

  • Keyframe the X position to -750 at 0.00

  • Keyframe the X position to -500 at 0.50

  • Keyframe the X position to 500 at 2.00

  • Keyframe the X position to 750 at 2.50

  • Inside the Widget Blueprint on construct play animation

  • Now use PIE to test the game

  • The Text should move across the screen and slightly halt towards the end of the animation

This is how it managed to reproduce it, However it seems keyframing different positions always throws off a different bug with the tween. For example when I first found this it would glide and then bounce backwards but with this method it has a hesitant unexpected pause in the animation around the 2.00 timing of the animation. There also seems to be another bug where the animation track says "No animation selected" Despite it being selected and me editing it although I can't replicate this.

Underneath are some screenshots of the blueprints:

Please fix this! It's caused me so much headache. Thank you for being so fast to reply and sorry for being a bit slow to reply.

avatar image Rudy Q ♦♦ STAFF May 16 '16 at 03:16 PM

Hello Sunshinewebsie,

Could you try changing your default curve setting for the animation that you using? You can do this by clicking the show curve editor button. From here you can set how you would like the transition to work between frames.

Example:

alt text

avatar image ElSnaps. May 18 '16 at 10:17 PM

alt text

Is that extra point supposed to automatically be there?

avatar image Rudy Q ♦♦ STAFF May 19 '16 at 01:20 PM

The only points that should show up are the ones that you have added. Have you been using auto key or perhaps could you have added it by mistake?

avatar image ElSnaps. May 21 '16 at 02:23 AM

No, I'm 100% certain I had AutoKey Disabled. I did actually check this before I posted and I've tested it and I haven't been adding it by mistake it just automatically appears there when I add the second keyframe

avatar image Rudy Q ♦♦ STAFF May 23 '16 at 08:04 PM

Hello Sunshinewebsie,

After taking another look at the picture, could you be a little more clear as to which extra point it is that you are referring to? In your original steps you provided four points and that is how many I see on the time line you have provided.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Sunshinewebsie,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered May 31 '16 at 03:43 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question