x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Turn off mesh culling distance?

Is there an option to turn off or change culling of mesh. I want to keep rendering no matter what the distance is. I turned off occlusion culling in the rendering but it's still the same. I also tried increasing the bound scale and it's still the same. I don't know if it's because of the size of the mesh is just small or something. It tried culling volumes too.

It's the missile compared to the cube, it stop rendering at around 15000 units. I created the mesh using bsp

alt text

Product Version: UE 4.11
Tags:
scale.png (454.2 kB)
more ▼

asked May 12 '16 at 11:01 PM in Rendering

avatar image

kurosu143
344 10 12 21

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hi kurosu,

Depending on the size of the mesh itself and how large it is on screen at the distance you specified it may just not have enough size to be visible. There is a certain point where if it's small enough on screen you won't be able to see it regardless. You can test this though by having Occlusion Culling Disabled and then moving the camera to the far distance you see where you think it's no longer visible. Then you can bring up the console window and enter the command FREEZERENDERING. This will allow you to freeze the rendering state for the scene as it is. You can then move the camera back in close and you should still see your object there being rendered. You can alternatively leave Occlusion culling enabled and do the same thing and this time you will see that it's been occluded.

I hope this helps.

Tim

more ▼

answered May 13 '16 at 01:42 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 99 875

avatar image kurosu143 May 13 '16 at 10:21 PM

Ok, I guess it's just really small, thanks.

(comments are locked)
10|2000 characters needed characters left

One thing that you can do is actually have the mesh get larger in its LOD. So in my case, I have some neon signs that are no longer visible once you're a few dozen feet away from them do to the fact that they are made of thin wire, so I added a Push modifier in 3ds max which makes them thicker and imported that as LOD1. This forces the mesh to stay on screen for longer than it would normally if you need an object to do so. Obviously you have to be careful as it will look weird if a mesh is getting noticeably larger the further away you are but its a good workaround in specific situations.

more ▼

answered Jul 10 '16 at 10:26 PM

avatar image

TorQueMoD
1.1k 81 110 143

(comments are locked)
10|2000 characters needed characters left

I found the culprit, it's the Temporal-AA. Small objects gets culled earlier when using Temporal-AA to prevent flickering if the object is very small on screen. When using other type of AA or none at all, objects will be culled later but causes flickering.

more ▼

answered Sep 29 '17 at 12:26 AM

avatar image

kurosu143
344 10 12 21

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question