x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HTML5 package when opened in Firefox Nightly, does not show anything.

Hello, I am trying to run the HTML5 package of a project on a Firefox Nightly browser. I am using UE 4.11.2 and latest Nightly build. I am unsure of what the issue is as I followed the instructions on Unreal Documentation. To my knowledge, there is no need of setting up/ installing Python or Emscripten SDK for this version of UE 4. Please let me know if I am mistaken.

As a test, I have also tried creating a very basic project with a floor and a cube. Even this did not work. Please help. Is there anything else that needs to be done apart from the documentation provided? Please see the image for reference.alt text

Product Version: UE 4.11
Tags:
more ▼

asked May 13 '16 at 04:56 AM in Packaging & Deployment

avatar image

ameygumaste
91 2 6 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

It is difficult to offer specific help based on only a screenshot of a page and a description that "it does not work", so any more information you are able to offer can help.

Some thoughts:

  • try opening the web page console (right-click on the page background, and choose "Inspect Element", and navigate to the Console tab). Are there any error messages there?

  • can you zip up or host the build somewhere for testing?

  • looking at the URL, you seem to have the cookonthefly feature enabled. Can you re-do the build where you disable that?

  • if you try exporting some other template/default content that UE4 offers, do any of those work? Try any of Empty project, StrategyGame, Sun Temple or PlatformerGame, those are known to export well.

more ▼

answered May 13 '16 at 06:49 AM

avatar image

juj
1.2k 15 4 17

avatar image ameygumaste May 13 '16 at 07:20 AM

Hello juj,

Thank you for your reply. The thing is that the new UE4 documentation describes that I just need UE4.11 and Firefox Nightly to make HTML5 packaging work. I am able to get HTML packed project work on my machine at home. I just followed the steps in the documentation and it started working.

Currently I am trying to make this project work on a machine at office. That is why I don't know where to start from, trying to troubleshoot this issue.

Regarding your suggestions:

  • Please see attached image with console errors.

  • I cannot share the project I am working on. But I have tried packaging a simple level with a floor and a cube. I have also tried packaging using the FirstPersonExample Map. Everything is showing the same output as you can see in the shared image.

  • I am not sure what 'cookonthefly' feature does or where it is located. I will check its documentation and try to make a package as you have said.

  • Have tried using default maps but result is the same.

I will try using a different machine with clean setup of UE4.11 and Firefox Nightly.

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

for the first image: cook on-the-fly will be fixed in 4.12....

for the second image: the file:// protocol is not supported -- you need to run the game from a webserver

more ▼

answered May 13 '16 at 09:55 AM

avatar image

nick.shin STAFF
476 5 4 9

avatar image ameygumaste May 13 '16 at 12:40 PM

Hey, Thanks for the response.

Regarding your second point, I tried using the HTML5LaunchHelper and typed the **'http://localhost:8000//Project_Name'** but,

  1. the browser gives me this error '404 Not Found'.

  2. The HTML5LaunchHelper shows the following

    Name: -Browser=

    Name: -ServerRoot= ./

    Name: -ServerPort= 8000

    Name: -BrowserCommandLine=

    Name: -UseAllPrefixes= FALSE

    Starting Server at http://localhost:8000/

    Press Any key Quit Server

    Not Serving .//VehicleIntegratedV02-HTML5-Shipping

    Not Serving .//favicon.ico

    Not Serving .//favicon.ico

avatar image nick.shin STAFF May 13 '16 at 07:48 PM

open the browser to:

a list of files will show up -- just click on the html file

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

I apologize for the late reply. I checked the HTML package output today, after a long time, on Firefox Nightly browser. And surprisingly it started working.

Following are the changes that were made to the system from the time I last posted this question:

  1. Updated to UE 4.12.1

  2. Installed Nvidia GTX 1080 with updated drivers.

I am not sure whether this has caused the packaged project to start working but I just double clicked on the HTML file that was packaged in May and opened it up in Firefox Nightly 64 bit.

Thank a lot for your help! Cheers!

more ▼

answered Jun 21 '16 at 04:40 AM

avatar image

ameygumaste
91 2 6 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question