x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

BT MoveDirectlyTowards does not work without NavMesh

This is on 4.12 Preview 2 (Launcher Version: 4.12.0-2962397+++UE4+Release-4.12), I tried to make a floating AI move around in 3D space using "Move Directly Towards" (which, according to the Tooltip, moves directly to the target without regard to any navigation system).

In practise, the Node fires, it takes some time to complete, but the Pawn does not move at all. As soon as a NavMesh is placed, the movement works correctly (which might be tricky in a freely floating space, but can be achieved with hidden planes).

To reproduce, create a new project, then create a new BP derived from either Pawn (which then needs a FloatingMovementComponent) or DefaultPawn (to get the component for free). Disable "Enable Gravity", set Movement Capabilities to either "Can Swim" or "Can Fly", then add a simple Behavior Tree that first picks a random point in space, then calls MoveDirectlyTowards on the selected point. "Project Goal Location" could be disabled, and for my case neither "Tracking Moving Goal" nor "Allow Partial Path" are required.

As is, this won't do anything, the pawn won't move. Place a NavMesh, and it suddenly works.

Product Version: UE 4.12 Preview
Tags:
more ▼

asked May 14 '16 at 11:44 AM in Bug Reports

avatar image

BhaaL
146 8 11 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

I have been able to reproduce your issue, and have entered a bug report, UE-30962. Thank you for your report.

Have a great day

more ▼

answered May 18 '16 at 06:03 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image Lyuro Dec 19 '17 at 03:19 PM

I'm trying to create a air navigation in 4.18.2, so i must use MoveDirectlyTowards & without NavMesh. And then I found this questions, this issue still same. I now give up using vector and using actor.

avatar image Sean L ♦♦ STAFF Dec 19 '17 at 04:28 PM

See the issue on our public tracker for more information, as this is currently working as intended: https://unreal-engine-issues.herokuapp.com/issue/UE-30962

Thanks

avatar image BhaaL Dec 19 '17 at 04:38 PM

I haven't checked lately, but the tooltip should then be amended to not give the false impression that it does indeed work without a NavMesh.

avatar image OmegaNemesis28 May 08 '19 at 08:22 PM

Very annoying and hard to find so many years later! This is still not updated today in 4.22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question