x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

An LMB event is only triggered with a double-click ?!

BP in question

Hello there :)

I'm encountering a strange problem and couldn't yet find a solution, albeit googling for hours. Please have a look and try your best :P

The plan here is as follows: When opening the world map (not included here) you can place "markers" and remove them. The InputAction is correctly set up, the marker actor that is placed is, too.

Now the problem with this is that I can click ONCE on the map, which gives me the "LMB registered" print AND places a marker.... but when I click again, on a different spot, I cannot trigger the same thing with only one LMB, I have to double-click in order to get the "LMB.." print and the marker to spawn. Same goes for the RMB for removing, btw.

The strange thing is that all this worked just fine until some hours ago. I can't remember what exactly it was that I've changed, but I'm pretty sure it wasn't on the level BP, but rather some different BP classes.

What could be the problem here?

Thanks, in advance,

Abaris

EDIT: The InputActions DO consume input, DO execute when paused and DO override parent bindings. All of these values have been changed in a trial and error manner, already.

The map is not a widget but replacing the player's camera with a "map camera"; the linetraces from this BP hit the ground - this worked everytime before.

Product Version: UE 4.11
Tags:
bp.png (338.7 kB)
more ▼

asked May 14 '16 at 02:33 PM in Blueprint Scripting

avatar image

Abaris919
54 4 6 31

avatar image Abaris919 May 20 '16 at 07:50 AM

Anyone? ( bump after 5 days )

avatar image Hum May 21 '16 at 01:30 PM

I'm having a similar problem. I have a simple LeftMouseButton event wired to a Print node in my player controller. I launch in editor and my first click prints "Hello" as it should but after the first click I have to double-click to get the same result. If I wire the Print node to a keyboard input it works fine, this seems to be just happening with mouse clicks whether its a bound input event or just a simple LeftMouseButton event.

I'm using 4.11.2. I'm wondering if this is a bug or if I changed a setting somewhere without realizing.

avatar image Hum May 21 '16 at 01:35 PM

One more thing. This is also happening when using an actors OnClicked Event. I have Show Mouse Cursor and Enable Click Events turned on in my player controller. This suggests it has nothing to do with how I'm handling mouse input.

avatar image Pypatron Dec 21 '16 at 01:09 PM

Hi, I have the same problem, but I dont understand what you mean with "forced "Set Input Mode to Game and UI" on all necessary points in all BPs that involve a click". Can you explain this? Is this a bug or what is the problem? In a new Blank-Project is nothing of this Problem but if i copy my existing project in the new Blank there is the same problem.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Aaaalright, after a LOT of trial and error I found a workaround that works for me:

I've forced "Set Input Mode to Game and UI" on all necessary points in all BPs that involve a click (or mouse focus, for that matter).

It seems the focus problem is solved by this and all LMB events trigger now, as intended.

more ▼

answered May 21 '16 at 05:03 PM

avatar image

Abaris919
54 4 6 31

avatar image cloudhime Nov 02 '16 at 05:43 PM

WOW geez thanks for following up on this because I was goin nuts trying to fix this. Previously when exiting a UI, I used the node "set to game mode only" but switching this node to game mode and UI fixed this immediately.

avatar image devDoer Feb 23 '19 at 02:47 AM

Thanks, Bro- Your solution worked for me as well.

avatar image Xnar Mar 05 '19 at 06:05 AM

Thanks! This image ended up being all I needed to do; added the Input Mode like this and done alt text

(comments are locked)
10|2000 characters needed characters left

Hi all, I was also experiencing this issue but had no idea what "Setting Input Mode to Game and UI on all necessary points" meant, but was able to google a solution in Project Settings --> Default Viewport Mouse Capture Mode --> select "Capture Permanently Including Initial Mouse Down" instead of "Capture Permanently".

I hope this helps someone else =)

more ▼

answered Feb 25 '17 at 09:09 AM

avatar image

OogaJiggaWooga
11 1

avatar image Pypatron Feb 25 '17 at 01:23 PM

Yes that is it. Had this bug for a long time. Thank you.

avatar image ZcheK May 30 '17 at 09:05 AM

Thanks that fixed it for me too.

avatar image urreek Nov 20 '17 at 04:43 AM

Try using FInputModeGameOnly::SetConsumeCaptureMouseDown and sett it to false in the player controller. :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question