x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Lightmap Not Producing Expected Results

Hello

In advance thanks for any assistance I'm new to using Unreal Engine and am trying to learn the necessities for realistic and clean lighting.

I have a static mesh that I created in Blender with 2 UV channels, one for texturing and one for the lightmap. The lightmap consists of 3 islands, one for the main trunk and one for each branch (see picture). Even with the lightmap resolution set to 1024 (really high as I understand) I am still getting the lighting result shown in the image below.

1st question is as follows: Is my lightmap UV acceptable, being new at all of this I have probably misunderstood articles I have read and created a UV that will never work.

2nd question, If that UV is fine then what else could it be?

alt text

alt text

Product Version: UE 4.11
Tags:
blender capture.jpg (158.0 kB)
ue4 cature.jpg (113.5 kB)
more ▼

asked May 15 '16 at 07:44 PM in Rendering

avatar image

JakeTheSnake96
8 1 2

avatar image saeedc May 15 '16 at 07:49 PM

take a look at this pagelink text

avatar image JakeTheSnake96 May 15 '16 at 08:31 PM

Thanks very much for the link @saeedc, there's plenty of helpful info on that page.

Cheers, Jake

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi there,

By the looks of it the shadow on the tree itself is fine, the shadow on the ground is what seems to be the problem. If it's the ground you are talking about then you need to increase the lightmap resolution of the ground asset as opposed to the tree, the lightmap UVs are for shadows which the objects receive itself, it doesn't affect how shadows appear on other objects.

I hope that helps. :)

-James

more ▼

answered May 15 '16 at 08:11 PM

avatar image

JBroderick
189 8 9 24

avatar image JakeTheSnake96 May 15 '16 at 08:31 PM

Thank you @JBroderick for the info, I was thinking about it in completely the wrong way. Now I know that that I'll have a play with it and hopefully get better results.

Cheers, Jake

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You're obviously using a directional light, most likely attached to a sky sphere BP.

Try this:

1) Select your directional light in the object list to the right and make sure it's Mobility is set to "Moveable". Not static or stationary.

2) While your directional light is selected, scroll down and raise the "Shadow filter sharpen" number from 0. to 0.5 or so.

3) Scroll down further and uncheck "Cast static shadows".

4) Make sure "Cast dynamic shadows" is checked.

If you've placed your tree as a static mesh by dragging and dropping it on the terrain, select it then check dynamic shadows, uncheck static shadows.

If you've placed it via the foliage tool, go back to the foliage painter tool and highlight the foliage type, scroll down and check dynamic shadows, uncheck static shadows.

If the tree is a blueprint, open the blueprint, select the static mesh component, uncheck static, check dynamic.

You're tree should now be casting a fairly accurate dynamic shadow.

Good luck.

more ▼

answered May 15 '16 at 09:40 PM

avatar image

Grant Margison
86 7 14 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question