x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to find UnrealBuildTool for ARM Linux compilation

Hi everyone, I am actually tring to build a little game on UE4 that would run on a raspberry pi 3. I was told I need to compile for a ARM Linux, and I've followed the tutorial on EU4 website. I've packaged my game and tried to run it on the Pi but I get the error : Cannot execute binary file: Exec format error. After looking to the tutorial again I noticed this part

" If you are using the Linux-ARM cross compile toolchain before running GenerateProjectFiles.bat below edit the following file in the UE4 source code: .../UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/UEBuildLinux.cs by commenting out the following line: static private string DefaultArchitecture = "x86_64-unknown-linux-gnu"; and un-commenting the linux-arm architecture line just below it: //static private string DefaultArchitecture = "arm-unknown-linux-gnueabihf"; "

That would probably be the reason of this error, because the compilation is not for ARM. However I can't find the files I need to modify. I follow the same path, but when I click on program, I only get UnreamHeaderTool instead of UnrealBuildTool. Any idea of how I could find the file I need to modify ? Maybe it is somewhere else ? Thanks for the help

Product Version: UE 4.11
Tags:
more ▼

asked May 15 '16 at 10:28 PM in Linux

avatar image

Dracico
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

UBT should be in the given path otherwise you would not be able to compile the project. You can see it in the github repository: https://github.com/EpicGames/UnrealEngine/tree/4.11/Engine/Source/Programs/UnrealBuildTool .

more ▼

answered May 16 '16 at 02:08 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image Dracico May 16 '16 at 03:26 PM

Thanks for the answer, I tried looking for it with your link on GitHub however the link seems to be broken, or maybe I'm doing something wrong but the page can't be found. and about the given paths you can see what I get on my picture.alt text

sans titre.png (8.8 kB)
avatar image RCL STAFF May 16 '16 at 04:06 PM

You don't seem to have your github account set up to access the repo - how did you get the source? Maybe UBT sources aren't distributed in binary only build...

avatar image Doug E ♦♦ STAFF May 16 '16 at 03:37 PM

The page is part of the Epic Games repo on Github and you will need to make sure you have linked your Unreal Engine account and Github accounts to access the page. The steps on how to link the two accounts can be found here:

https://github.com/EpicGames/Signup

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question