x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Grappling Hook Tutorial! Works Great - but Uncovered Major Inconsistency regarding UE4 Inputs!

I followed this Grappling Hook Tutorial for a Third Person Project, and it works great. (I would definitely recommend it)

You're supposed to be able to move the character in any direction, while the grappling hook is locked onto an object in your crosshairs - which you can (the code works fine). However, I found a Major Inconsistency regarding UE4 Inputs!

I can move Up (forward), Down (back), Right, and Left - "INDEPENDENTLY" with no problems - whether grappling cable is locked onto an object or not

However, when the grapple cable is in fact locked onto an object - I can move ..Down/Left, Down/Right, Up/right .....but "NOT" Up/Left !!

alt text

The pic above demonstrates Down/Right works fine. (And Up/Right also works fine).

The pic below demonstrates Down/Left works fine. [Up/Left - Does Not!] - why doesn't Up/Left work?

alt text

  • If - I replace the "Left" button Input, with "Any other button Input" - It works just fine??

  • for example - when W, A, S, D keys are assigned, everything works without any issue??

I can find Absolutely NO Explanation for this Behavior!!! I know the code is fine and I know it's Not a settings issue because it Works when you Simply change the Input to Any other button Input except "Left" ..and it works fine.

Has anyone else ever experienced anything like this - when an Input works for one button press, but Not another?

I'd love to hear a good explanation for this if anyone has one....

My Keyboard Inputs:

  • Axis Mappings: Move Forward - Up = 1 / Down = -1

  • Axis Mappings: Move Right - Right = 1 / Left = -1

..I also tried creating an Action Mapping for "Move Left" with no success.

Product Version: UE 4.10
Tags:
more ▼

asked May 16 '16 at 10:29 AM in Bug Reports

avatar image

vicecore
18 4 6 11

avatar image Adam Davis STAFF May 16 '16 at 05:50 PM

Hi vicecore,

Please check to ensure that the input key you are using is not possibly being consumed by any other actor or character blueprint. If it is not, are you able to reproduce this error in a clean, blank project with no additional content or is it limited to one project?

avatar image vicecore May 16 '16 at 09:32 PM

Adam, thanks so much for you timely response.

To answer your question, I started with a blank Third Person Template. So the input key I'm using are not being consumed by any other actor or character blueprint - or assigned to any other functions.

Also, I tried to redo everything again in another blank 3rd Person Template, and got the Exact Same Result. W,A,S,D (or any other button inputs) work just fine.

I'm convinced this is a ":glitch" with UE4 Inputs ...although I hope I'm wrong. Thanks again, I really appreciate you looking into this for me.

I attached the code - if this makes it easier for you to test.

In addition: The pictures show cable Variables and Settings

You would need to activate visible crosshairs in game play (which I assume you have) Any problems there, let me know ..thanks again

link text

alt text

alt text

alt text

avatar image vicecore May 17 '16 at 03:37 AM

..also just wanted to mention that when you start a default 3rd Person Template - "Left" button Input is initially set for Turning the screen left & right.

I deleted those Axis Mappings and replaced them with A & D - so on my projects - "Left" has no conflicts

avatar image Adam Davis STAFF May 17 '16 at 07:00 PM

Unfortunately I can't really see what you have going on in the images presented. Can you send me a sample project this is occurring in? I'll be happy to take a look and see if I can figure out what is going on.

avatar image vicecore May 18 '16 at 08:54 PM

Hi Adam, I'd be more than happy to send you the project..

How should I go about doing so?

Can you give me instructions, or leave me a link to a resource on how to do this this.

Thanks again for looking into it for me

avatar image Adam Davis STAFF May 19 '16 at 03:31 PM

The best thing to do would be to zip your project into a zip file and upload the zip here. If it is too large, you can upload it to an FTP service such as Dropbox or google drive and provide the link. If privacy is a concern, you can send me the link by sending a private message to my forum account here:

https://forums.unrealengine.com/member.php?49-Adam-Davis

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi vicecore,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered May 23 '16 at 05:50 PM

avatar image vicecore Jun 02 '16 at 06:07 PM

Hey Adam, sorry it took so long to get back to you. I finally made a zip file, but can't seem to attach it here in the answer hub (which I have no problem doing- no privacy issue) I'm just not sure how to get this zip file to you? Can I email it to you?

avatar image Adam Davis STAFF Jun 02 '16 at 06:14 PM

If you upload it to an FTP site such as dropbox you can post the link here or send it in a private message to me on the forums via this link:

https://forums.unrealengine.com/member.php?49-Adam-Davis

avatar image vicecore Jun 02 '16 at 08:14 PM

https://www.dropbox.com/s/xxn4tzkmwgqnopv/GrappleSystem.zip?dl=0

https://www.dropbox.com/sh/aodly3bt2gp4ahp/AAB9sJ2jxGhugCHRe4N4XWnFa?dl=0

Hopefully one of these will work ...thanks again. let me know if you were able to access it

avatar image Adam Davis STAFF Jun 03 '16 at 01:39 PM

What should occur when I look at these? What specific error is occurring when you press input keys?

avatar image vicecore Jun 03 '16 at 04:50 PM

Ok Adam ..so I'm assuming you were able to download the project successfully. So basically, when you target something in your crosshairs and press (Hold) the "G" key, the character will attach grapple cable to a post.

While attached, you should be able to move Up, Down, Left and Right - independently - with no issues.

While Attached... - You'll notice you can move Down & Left simultaneously.

  • You can also move Down & Right simultaneously.

  • You can move Up & Right simultaneously.

...however, for some reason - you Can Not Move Up & Left simultaneously!

I'm not sure why that is - project is basically blank with no input conflicts. Now if you were to reassign my (Up, Down, Left, right) key inputs with W,A,S,D - Up & Left simultaneously works just fine.

As additional proof, I have the (right, Ctrl key) assigned to move left in the inputs - and everything works fine when you use that key, the system is just bias to the Left key input for some strange reason.

I'm hoping you can test it with this info, and confirm my results exactly.. as I was able to reproduce this glitch on several other projects & computers.

Thanks so much again for looking into this....

avatar image Adam Davis STAFF Jun 03 '16 at 06:33 PM

Unfortunately no, moving up and left using the keyboard produces the exact results I expect. The player moves forward and to the left simultaneously without any jerking movements or alteration, the character instead moves in a straight, diagonal line. Try running a print string before the movement of your character, check to see if the movement input is registering both keys when pressed or if one is registering and the other is not.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question