x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why engine not replicating UClasses?

I use TArray of UStructs variable and one of fields of struct is TSubclassOf. And array is replicated, but all fields with TSubclassOf is nullptr after replication. What's wrong? Classes is immutable objects, why fields can't be replicated?

This struct:

 USTRUCT()
 class FSomeStruct
 {
     GENERATED_USTRUCT_BODY()
 
 public:
     UPROPERTY()
     FString StringField;  // replicated succesfully
 
     UPROPERTY()
     int32 IntField;  // replicated succesfully
 
     UPROPERTY()
     TSubclassOf<UMyClass> ClassField;  // not replicated, got nullptr
 
 }

Replicated array:

 UPROPERTY(Replicated)
 TArray<FSomeStruct> SomeStructsArray;

Thanks!

Product Version: UE 4.11
Tags:
more ▼

asked May 18 '16 at 09:32 AM in C++ Programming

avatar image

broly
379 23 31 45

avatar image Shadowriver ♦ May 18 '16 at 05:41 PM

Did you tried if normal UClass* works?

avatar image broly May 18 '16 at 07:50 PM

Did not tried just UClass*.

One more detail: With editor works normal, but with dedicated server and standalone clients got this.

My solution was store replicated Class Path Name of class string value and using LoadObject with this string to get class object. But it looks like a redundant code...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question