x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.12 dedicated server crash when client login

I'm using the latest 4.12 version from github, my project is upgraded from 4.11,

when a client connects to server, the server will crash immediately.

alt text alt text

Product Version: UE 4.12 Preview
Tags:
crash02.png (43.3 kB)
crash01.png (13.5 kB)
more ▼

asked May 20 '16 at 12:09 PM in Bug Reports

avatar image

darren_mii
93 4 11 9

avatar image Matthew J May 20 '16 at 02:28 PM

Hello darren_mii,

Were there any changes made to your project before this began occurring or was it directly after upgrading to the 4.12 Preview? If changes were made, have you tried integrating those changes into your old 4.11 build to see if the same results occur?

avatar image darren_mii May 20 '16 at 05:39 PM

Hello Matthew,

No, I did not change anything to my project, but I did modify the engine code,

I get this error when I build the engine:

16>D:\Unreal\UnrealEngine-4.12\Engine\Source\Runtime\Core\Private\Internationalization\Cultures\InvariantCulture.h(43): error C4566: character represented by universal-character-name '\u2030' cannot be represented in the current code page (950)

So I change that character to other thing and the engine can build without error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Thank you everyone for your help in getting this bug reported. This still occurs in our latest internal build so I've placed a report in under the number UE-31850. Unfortunately, since I don't know the exact cause, I can't provide anything in the way of a workaround at the moment. I'll be sure to update you all whenever any changes are made to the report.

Have a nice day!

more ▼

answered Jun 09 '16 at 09:54 PM

avatar image Anorian Jun 13 '16 at 08:55 AM

Any update on UE-31850 please? We really need this fixed badly. Thanks

avatar image mdunham Jun 14 '16 at 01:57 PM

Looking for an update as we are having this issues as well.

avatar image 任遊 陳龍進 Jul 20 '16 at 10:20 AM

Hi, Is there any info updates about this bug after a month?

avatar image Matthew J Jul 21 '16 at 08:55 PM

Hello everyone,

Currently this bug is marked as Backlogged and isn't getting much attention. I'm making an effort to get some more attention put on it since it is blocking a few people and is a regression from 4.11. To try to get an accurate example of how many people this is affecting, can anyone being affected by this (since I imagine not everyone has posted) put an upvote on the original question? I'll give an update on the status when I know more.

avatar image Matthew J Jul 21 '16 at 09:54 PM

Actually, in testing this, I'm not able to get it to occur any longer with 4.12.5's source. Have any of you tried that version? If so, are you getting the same results?

avatar image darren_mii Jul 23 '16 at 04:10 PM

Thank you Matthew,

I just tried with 4.12.5, the server did not crash. Looks like this issue has fixed.

avatar image Medvega Jul 25 '16 at 12:43 PM

Tried 4.12.5 myself, don't see this issue anymore.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the exact same crash, on the same line:

[2016.06.05-04.36.47:207][454]LogWindows:Error: === Critical error: === Assertion failed: CharacterOwner->GetRemoteRole() == ROLE_AutonomousProxy [File:D:\Unreal 4.12\UnrealEngine-release\Engine\Source\Runtime\Engine\Private\Components\CharacterMovementComponent.cpp] [Line: 6915]

I'm using the release branch from GitHub. The crash happens every time when the client connects to the dedicated server in a packaged build.

more ▼

answered Jun 05 '16 at 04:40 AM

avatar image

CodeSpartan
271 12 113 34

avatar image darren_mii Jun 08 '16 at 07:49 AM

I can confirm this issue still exists, what I tried before is using UE4Editor.exe with -game and -server command. But if you use a packaged build, server will crash just like CodeSpartan said. I'm using the latest 4.12 branch, which is 4.12.2 now.

avatar image CodeSpartan Jun 08 '16 at 11:10 AM

I believe we need to provide a repro project as per this guide. My project is quite big, I'm currently trying to make a smaller repro project, but don't know if I manage to do that.

Here are the crash log and minidump:

crash info.zip (45.3 kB)
avatar image Matthew J Jun 08 '16 at 03:10 PM

Thank you for looking up that guide, CodeSpartan. Having a reproduction project would eliminate the need for me to find the exact cause of the problem and create one of my own, meaning I can get a bug report in immediately and have a developer who would know much more about the subject looking at the issue as soon as possible.

avatar image CodeSpartan Jun 08 '16 at 05:12 PM

Hi Matthew,

I've found some quick repro steps that you can use:

Repro Steps

You will need a source-build 4.12+ engine (I used 4.12.1)

  1. Create a new Blank blueprint project without starter content, name it "Bug"

  2. set the World Override GameMode to (new blueprint) NewGameMode

  3. create a new blueprint, deriving from Character and name it NewCharacter

  4. create a new blueprint deriving from NewCharacter and name it ChildCharacter

  5. create a new blueprint deriving from ChildCharacter and name it GrandchildCharacter

  6. in Project settings - Maps & Modes set the Game Instance Class to (new blueprint) NewGameInstance

  7. in NewGameMode, set the default pawn to ChildCharacter

  8. in NewCharacter, create a variable of type NewGameInstance

  9. in GrandchildCharacter, create a variable of type NewGameMode

  10. in NewGameMode, create a variable of type NewGameInstance and a variable of type GrandchildCharacter

  11. in NewGameInstance, create a variable of type NewGameMode and a variable of type GrandchildCharacter

  12. Save the new map and set it as Editor Startup Map, GameDefault Map and Server Default Map in Project - Maps & Modes

Done! Test the game in editor with "Run Dedicated Server" checked - it launches fine. Now you can build the dedicated server and package the game. The dedicated server in the packaged game will crash instantly when the client connects.

Just in case, here are the steps I used to build and launch the dedicated server: 1. from the editor, add an empty c++ class 2. place BugServer.Target.cs (attached) in the project's Bug/Source folder 3. right-click on .uproject - Generate Visual studio project files 4. Package the game 5. Reopen VS, Build with configuration Development Server 6. copy BugServer.exe from the project's folder Binaries/Win64 to the packaged game's Binaries/Win64 8. launch BugServer.exe with -log parameter 9. launch Bug.exe with 127.0.0.1 parameter

I've attached the repro project in case you need it.

avatar image Matthew J Jun 09 '16 at 08:22 PM

Thank you for the detailed reproduction steps. I've reproduced the issue and will be placing a bug in for the issue shortly. I'm currently testing to ensure that it is new to 4.12 and also testing to see if it works or not on our latest internal build. I'll get back to you all soon with the results of that.

avatar image Anorian Jun 13 '16 at 03:50 PM

Any updates on this please? We've got a project ready for an update release on Steam here completely on hold because of this issue.

avatar image Matthew J Jun 13 '16 at 03:53 PM

As I mentioned, when any changes are made to the bug report or if we have more information, I'll update you here. Until then, there isn't much I can say. It may be helpful to look into the information that Zeiten posted as he seems to of found a workaround.

avatar image Anorian Jun 14 '16 at 10:41 AM

Ok, thanks Matthew. Btw, what/where/who is that info "Zeiten" has posted pls?

avatar image Matthew J Jun 14 '16 at 02:00 PM

It seems like Zeiten deleted it. While I can't just bring their post back, I'll post what I remember.

They attempted reproducing the same issue in 4.12.2 but included starter content, although CodeSpartan mentioned not to. According to them, including that Starter Content worked around the issue that we're seeing here. Through more testing, they added that it wasn't necessarily the Starter Content, but the map it was on. They added a new level with Basic Atmospheric Fog, a simple cube, and a player start. After doing that, it worked fine.

avatar image Anorian Jun 15 '16 at 11:26 AM

Tried this now. No Cigar ;(

[2016.06.15-11.21.09:416][202]LogNet: Join succeeded: Gerhard-PC-F36F0B904 [2016.06.15-11.21.09:419][202]LogWindows: Windows GetLastError: Der Vorgang wurde erfolgreich beendet. (0) [2016.06.15-11.21.09:672][202]LogWindows:Error: === Critical error: === Assertion failed: CharacterOwner->GetRemoteRole() == ROLE_AutonomousProxy [File:E:\UnrealEngine-release\Engine\Source\Runtime\Engine\Private\Components\CharacterMovementComponent.cpp] [Line: 6915]

avatar image xCPx Jun 15 '16 at 02:54 PM

Actually even if you do it like Zeiten said. You fix that one crash problem, but others appear. For Example for me : Packaged Server then cannot spawn the Pawns because it says "cannot spawn because of collision" even on a completly empty map if you set the PlayerStart to a Point where nothing is. After you switched all Default Classes to new Classes the Errors dissapear. But you would have to rewrite your whole game in 4.12 what isnt what its expected to be or?

Thats why he deleted the Post i think.

Actually noone with a bit bigger project can run dedicated servers from it :/

avatar image Matthew J Jun 15 '16 at 03:06 PM

Unfortunately if we can't find a workaround, the only thing I can suggest is to revert to an earlier version of the editor where the crash didn't happen. The bug will be reviewed and fixed in due time but there's no guarantee on when the fix will be made or integrated at this time.

avatar image xCPx Jun 08 '16 at 11:07 AM

I too can confirm this Error. Like i saw it happens if you got circular dependent Classes that are updated from another UE version.

if you full delete everything and do it on ue 4.12, then it works. But basically it should be fixxed. I dont wont to update about 30000 blueprint functions x.x

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Matthew,

I updated the latest code on the github today, and this issue is gone,

thank you UnrealEngine team!

more ▼

answered May 24 '16 at 06:33 AM

avatar image

darren_mii
93 4 11 9

avatar image Matthew J May 24 '16 at 01:52 PM

Glad to hear that the issue is resolved!

avatar image CodeSpartan Jun 05 '16 at 04:44 AM

it is still present for me with UE 4.12 and 4.12.1, I'm using the release branch from GitHub. With Preview 5, the crash happened in editor, with 'release' build it only crashes in the packaged game

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question