x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Unable to build AutomationTool on Ubuntu 16.04 LTS

There is a problem in the build script of the AutomationTool. When i start up UnrealFrontEnd, after i built the engine, i try to cook and pack a project. The tool then tries to compile UAT, but fails because unresolved symbols. I solved this by building it myself by copying the command that was shown in the UnrealFrontEnd and pasting it in my terminal, then i added: /p:TargetFrameworkVersion=v4.5 Once the tool was built i had no longer problems.

Product Version: UE 4.11
Tags:
more ▼

asked May 20 '16 at 04:29 PM in Bug Reports

avatar image

Joejoepie
1 1 2

avatar image Doug E ♦♦ STAFF May 23 '16 at 03:51 PM

Hey Joejoepie-

Do you have the same error trying to use File->PackageProject->Linux? What is the exact error message you received that mentioned the unresolved externals? If you are able to reproduce this in a new project, please include the steps used to setup the project?

avatar image Joejoepie May 23 '16 at 08:24 PM

Hi, yes this was the same result. And the errors i was getting was that UAT failed to build, and this was due to not finding System symbels, like Sytem.Object and System.Xml and the like. It was on a french install of ubuntu 16.04.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I did come across a known issue with the Automation Tool for Linux. You can try incorporating the associated pull request (https://github.com/EpicGames/UnrealEngine/pull/2397/files) into your engine build to see if it solves the packaging issue you're seeing. Let me know if you have further questions.

Cheers

Doug Wilson

more ▼

answered May 24 '16 at 07:41 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question