x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint uncompiles when restarting editor

I have a game where most of HUD is made using blueprints, but three of widgets won't work normally for unknown reasons.
I've just started the editor, it's fresh and clean, and immediately ran play-in-editor. The gun is depends on what HUD chooses and if nothing was selected the gun will shoot as defaults saying. Usually if there at least anything in HUD gun will choose defaults from HUD and shoot differently.
When game starts Game Instance loads up all presets for gun from specific folder and sends them to HUD to display, so I thought that the only reason for gun to "shoot it's defaults" is if there will be nothing loaded from folder. Apparently not. When I opened up library I saw this:
BadLib
These small buttons are in their default state, but Game Instance actually sent data (that I call setups).
I also should mention that editor gave me no warnings.
So when I've tried to launch PIE again editor now said that for these three types of widget there is an compilation errors. I checked an errors, all about the same function, but still doesn't makes sense:
StrangeBP This function does exists in LibraryWidget, but for some reason it wasn't hooked up. Of course if I just recompile then everything's fine, but this is really annoying to recompile each time I need to restart the editor, especially if I'am still not so good programmer and my code crashes the editor pretty often.
What is wrong with blueprints?

Product Version: UE 4.11
Tags:
badlib.png (976.5 kB)
strangebp.png (95.4 kB)
more ▼

asked May 22 '16 at 06:04 AM in Blueprint Scripting

avatar image

HungryDoodles
490 29 24 40

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This problem is gone in UE 4.12. Looks like it was a bug.

more ▼

answered Jun 07 '16 at 05:20 AM

avatar image

HungryDoodles
490 29 24 40

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question