x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

RunEQSQuery deprecated?

In 4.8 and 4.9 I was able to run EQS queries from the Behavior tree.

Now when I try in 4.11 I'm getting deprecated node. I see a run EQS query node in standard tasks... and I've tried this but they come back blank.

Is RunEQSQuery really not doable from the BT anymore? Whats the proper way now?

Product Version: UE 4.11
Tags:
more ▼

asked May 24 '16 at 01:16 AM in Blueprint Scripting

avatar image

thankstipscom
654 39 38 72

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

its gotta be a bug... i just tried the exact same setup on 4.8 and it works right away. But i cant believe no one has come across this in 4.11, its a big deal if its a bug... so i donno.

Yes I tried both custom aicontroller that runs the BT and BB. I also tried standard AI controller. I tried spawning the AIclass with the BT set from the levelBP and I tried manually placing the actor in.

alt text

eqs_pic4_48.png (744.7 kB)
more ▼

answered May 24 '16 at 03:08 AM

avatar image

thankstipscom
654 39 38 72

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

you mean this?

alt text

eqs2.jpg (282.4 kB)
more ▼

answered May 24 '16 at 01:33 AM

avatar image

jblaswu
813 22 11 46

avatar image thankstipscom May 24 '16 at 01:51 AM

I tried that.. it didnt work. It just loops never setting the BB key The EQS is simple... find CharHeroBP (which would be me the player.. so im definitely in there to be found. I set it to 6000 ... should find me when im like next to the AI.

alt text

eqs_pic.png (108.6 kB)
avatar image jblaswu May 24 '16 at 01:53 AM

from the screenshot, the Run EQS Query is never setting the blackboard key, the value is at none, is that correct?

avatar image thankstipscom May 24 '16 at 01:56 AM

Yes. Thats right. Well it says invalid. Its the Vector key called Target. I tried it with the object key as well called Player and it also doesn't set it.

avatar image jblaswu May 24 '16 at 02:04 AM

oh, i actually didnt see it was selected on the dropdown. my guess is that its running the EQS and getting stuck cause theres no value and its not resetting.

i would use a setup like this, this way, the EQS will run as service and autoupdate, pretty much like running it in parallel. not sure how much it affects on perfomance tho.

also, the 2nd screenshot is an example for other guy who wanted an AI that moves to the player and does something, this is pretty much the same. More screenshots with details here https://answers.unrealengine.com/questions/343564/parallel-execution-in-behavior-tree.html

EDITED:FIXED the order of the screenies. 2nd EDIT: i just realized your EQS is setting the key to Target, but you are trying to move to Player.

alt textalt text

bt3.jpg (948.4 kB)
chasingfire.jpg (338.1 kB)
avatar image thankstipscom May 24 '16 at 02:11 AM

Yea that was my mistake in taking the screenshot. It wasnt move to player when i was testing. I was just trying to set it to either key in case the EQS finding a class needed an object to be set to (it doesnt on previous versions). I forgot to revert that back before taking the screenshot. Sides then the move to would fail but not the setting of the key which never happens.

I literally copied this set up from my previous project where it still works in 4.8.

Its not getting stuck. Its just failing. I put the wait in front of the EQS query and it waits runs the query and then waits again....never setting the BB key. Either the key is never gettting set or the EQS is never being run. If its the latter, setting it up as a service would have the same problem technically if the issue is with the EQS... but ill try it.

avatar image jblaswu May 24 '16 at 02:18 AM

are you using the EQS pawn to test your Query? does it reports succesful results?

also, is the branch on top of your screenie the root? or it comes from another logic?

avatar image thankstipscom May 24 '16 at 02:26 AM

I'm not using the EQS pawn. I have a charEnemyBP in the map that spawns which is running this tree.

Its got a navmesh set up. it should be able to move around ok. I tried putting a targetpoint and changing the EQS to look for TP actors instead.. same results.

Still no luck with this. The other logic is

Player Set do x DynamicTargetSet do y

then

this... if DynamicTarget is not set.. then set player

Dynamic Target only gets set from the pawn itself from PawnSensing.. sight or hearing... none of that is added to the enemy yet so its not interfering. I did remove the other logic tho and tried running this direct. Same results.

alt text

eqs_pic2.png (87.4 kB)
avatar image jblaswu May 24 '16 at 02:40 AM

Using the tree i put at the beginning it does what you want it to do...and the EQS testing pawn should tell you if you are doing the query correctly. my query is on the screenie, if needed. Also, i got a similar tree that might be useful, but its a little more complicated. Red Text summaries what it does. I do extensive use of observers to work as switches.

alt textalt textalt textalt textalt text

bt_1.jpg (715.8 kB)
bt_2.jpg (696.1 kB)
bt_3.jpg (747.5 kB)
eqsquery.jpg (163.3 kB)
mytree.jpg (982.6 kB)
avatar image thankstipscom May 24 '16 at 02:44 AM

Thanks! Before I make any dramatic changes.... what version of the engine are you running?

I just tried this in a fresh 4.11 TPS project and getting same results. not sure what im doing wrong exactly.

alt text

eqs_pic3.png (725.3 kB)
avatar image jblaswu May 24 '16 at 02:51 AM

master branch, but i doubt thats the issue. needless to say but are you executing Run Behavior Tree on the AI Controller? also, is the AI Controller set on the AI Pawn?

avatar image jblaswu May 24 '16 at 02:46 AM

Adding the details of the EQS Queryalt text

eqsquery.jpg (824.5 kB)
avatar image thankstipscom May 24 '16 at 03:29 AM

And i tried the same test on 4.12 preview 4 and it DOES work....

so confused as to what would be different in 4.11

avatar image jblaswu May 24 '16 at 03:44 AM

then it has to be a bug, you should report it

avatar image thankstipscom May 24 '16 at 04:04 AM

yeah... adding a test does make it work i guess in 4.11 not sure how to use them yet since i havent seen these tests before today.

Thanks again for helping out!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question