x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Package BUILD FAILED

Not sure why the packaging isn't working. It was working in 4.10.. I hadn't built for a while. I tried out different maps but I still get a build fail.

I've uploaded the error log.

I'm really lost when it comes to this stuff so I'd really appreciate the help. THANK YOU! Vince

link text

Product Version: UE 4.11
Tags:
buildfailed.txt (2.4 MB)
more ▼

asked May 24 '16 at 03:23 AM in Packaging & Deployment

avatar image

spinav
56 2 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hello spinav,

After looking through your logs I was able to find that you have a few issues that need to be cleaned up.

Error:

UE4Editor-Cmd: [2016.06.02-16.32.39:680][ 0]LogInit:Display: LogBlueprint:Error: [compiler VehicleBlueprint] Error The property associated with Follow Hmd Orientation could not be found

My Fix:

I opened the VehicleBlueprint and removed the reference to Follow Hmd Orientation (you will see that this blueprint has a compile error). As you can see at the end of the error it states the issue.

Error:

0]LogInit:Display: LogBlueprint:Warning: Node '/Game/Blueprints/Skybox.Skybox:UserConstructionScript.K2Node_FunctionEntry_10' missing NodeGuid because of upgrade from old package version, this can cause deterministic cooking issues please resave package.

My Fix:

I opened the skybox blueprint and hit the save button. This cleared out the error above and any others that ended with "...deterministic cooking issues please resave package."

I didn't get a chance to copy the error down but I had to open the starter map to update the DDC.

You will need to run through you log and try to resolve as many of these issues as possible. I was able to packed the project after the above changes were made.

Make it a great day

more ▼

answered Jun 02 '16 at 05:36 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

at some point it looks like you had a Struct and got deleted. i have read theres a bug about broken references. Whenever i have this kind of issues:

  • Delete Intermediate folder

  • Delete Saved folder

  • Delete Binaries folder

  • Inside your project, right click on Content (inside Content Browser), "Fix Up Redirections in Folder".

ofc, if in doubt, backup your project first. also, have you tried building a sample template?

more ▼

answered May 24 '16 at 04:42 AM

avatar image

jblaswu
813 22 11 46

avatar image Rudy Q ♦♦ STAFF May 24 '16 at 02:28 PM

Hello spinav,

Could you try the suggestion about provided by jblaswu and let me know if this helps? If you need further assistance after this I will be more than happy to help.

avatar image spinav May 24 '16 at 04:11 PM

Hello, I'm currently backing up the project. I've located the Save + Intermediate Folders but Not the binaries folder... is it possible because I'm doing only Blueprinting there's no Binaries folder?

avatar image spinav May 24 '16 at 04:37 PM

Hey so I noticed the Binaries folder was inside the Saved Folder.

I deleted them and did 'fix up redirections in folder' Still no luck.

I tried packaging another project with 4.11.2 and it worked fine. So there has to be something wrong with my current project. Any other ideas?

Here's the latest log link text

avatar image spinav May 24 '16 at 05:30 PM

I thing I forgot to mention was I had an issue when copying from 4.10 to 4.11, where assets were not referenced. I did the trick that was suggested in the answerforum, which was to change the foldername then switch it back. That fixed the issue. Perhaps it fixed that issue but made one for the build/Packaging?

avatar image Rudy Q ♦♦ STAFF May 24 '16 at 06:52 PM

Hello spinav,

Would be possible for you to provide the project so that I can take a closer look?

avatar image spinav May 24 '16 at 07:23 PM

i just winrared it and it's 4.9 gigs :Z what's the easiest way to send it over

avatar image spinav May 24 '16 at 07:31 PM

Sorry make that 1.2gb, i accidently had the backup in the rar as well.

avatar image Rudy Q ♦♦ STAFF May 24 '16 at 07:43 PM

You could provide it via dropbox or google drive. If you would like to provide it privately, you could do so by sending it to me in a private message on the forums.

avatar image spinav May 24 '16 at 10:34 PM

uploading it now, I'll msg you when it's done. Thanks a bunch Rudy!

avatar image jblaswu May 24 '16 at 11:18 PM

all the errors are linked to "Follow Hmd Orientation" and one " Unknown structure" (which i think its a bug). What is that "Follow Hmd Orientation"? is it properly debugged? is your project c++? does everything compiles fine?

avatar image spinav May 25 '16 at 12:20 AM

not sure what Follow Hmd Orientation is...what would Hmd stand for? Could it be a AI Move to? About the unknown structure, how can I figure out which one that is? No I'm doing only blueprinting.

-Also 13 minutes until it's uploaded.

avatar image jblaswu May 25 '16 at 12:25 AM

seems like the "Follow Hmd orientation" has something to do with camera functions. https://docs.unrealengine.com/latest/INT/BlueprintAPI/Input/OculusLibrary/EnablePlayerCameraManagerFollowH-/index.html

i also seems like the error comes from your vehicleBlueprint only. have you tried to remove that actor from the level and build the project?

avatar image spinav May 25 '16 at 12:51 AM

I'll try that, I do have a vehicle in my game. Thanks!

Also Rudy How do i send you a pm?

avatar image spinav May 26 '16 at 03:22 AM

I tried removing it from the level, and it still fails to build :(

avatar image jblaswu May 26 '16 at 03:50 AM

that is really odd, if its not there it should be skipped on the build...could you upload the new log?

avatar image Rudy Q ♦♦ STAFF May 26 '16 at 12:59 PM

Hello spinav,

I wanted to let you know that I have received the project on the forums and that I will begin investigating the issue.

avatar image spinav May 27 '16 at 12:22 AM

Thanks! I really appreciate the help :)

avatar image spinav May 27 '16 at 09:48 PM

Any news :)

avatar image spinav May 30 '16 at 03:17 AM

Hey Rudy!! I was messing around with the landRover BP and i have this error.. it's telling me to contact the blueprints team... I have no idea what to do, how to fix it. alt text

error.jpg (236.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Nevermind i found the culprit. It's theCanpickup_BP for some reason it had astruct that was causing the build to fail. i deleted it and it works now.

Thanks for the help!

more ▼

answered Jun 02 '16 at 05:11 PM

avatar image

spinav
56 2 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question