x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Externally Referenced Asset Warning (Project Rename Doesn't Fix)

I have all of my projects stored on the server, which may be the problem. I don't need to cook or build the game, as I am only rendering. Having to wait for the warning dialog to come up to say it's fine that there are externally referenced objects slow down the creative process. I tried the project double rename fix multiple times, as well as starting a new project. A new project will be fine for a while and then it will have the error again, potentially due to things being migrated to or from the project? I'm not sure. Does anyone have any fixes for this?

Product Version: UE 4.11
Tags:
more ▼

asked May 25 '16 at 11:18 PM in Using UE4

avatar image

AaronAikman
145 8 14 26

avatar image Sabun Jun 16 '16 at 04:09 AM

I just wanted to add that I experience this issue as well. My case may be a bit different however.

I have a project on Windows, using the 4.12.0 binary editor. When I copy over this project to Mac and proceed to open it with either the source or binary version of 4.12.0, the external references warning will pop up. This is a serious problem, as packaging with this warning prevents the maps or assets from being included in the packaged build.

I have also tested this in 4.12.1 and 4.12.2 with the same outcome. The project was initially on Windows under version 4.10.4. After upgrading it to 4.12, this issue has come about. It's not the first time though, bringing anything from Window's editor over to the Mac editor always produced this problem. Only now, we can no longer solve it by the renaming the folder trick.

Doing a clean copy via editor, or an in-place conversion does not change the outcome either. Neither does removing the folders Intermediate, Saved, Build or Binaries.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

have you tried deleting Intermediate, saved and binaries folder?

more ▼

answered May 25 '16 at 11:34 PM

avatar image

jblaswu
813 22 11 46

avatar image AaronAikman May 25 '16 at 11:35 PM

I have, to no avail, unfortunately.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question