x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UNavArea not applying over the top of UStaticMesh.

Hey so I'm having some issues with the NavArea class and how to get my mesh to generate the way that I want. These are the results I'm seeing from my testing

NavMesh

atm on my Static Mesh I have set it up so the platforms have obstacle set and the stairs do not.

StaticMesh

The Actors on the right with the StaticMeshComponent just have these settings

alt text

so the obstacle setting will do as its meant to and skip trying to lay the navmesh out on top of the static mesh but it does use the custom NavArea that I have setup so that the bridges are used more.

alt text

It will only use the NavArea if using the obstacle setting. What I would like is for it to cover the top of the walkway with my custom NavArea, anyone able to point me in the direction of what I need to fix, I have tried messing with the project settings for the NavigationMesh and the NavigationSystem, and I have the shape and generation working how I want. We did have a seperate solution where on the blueprint object we would add additional BoxCollision components to the blueprint object, of which we could paint with the NavArea, but we were seeing ALOT of issues with our agents getting caught on the additional physics and stuck. Removing these shapes fixes this problem which was a much higher priority for us than having our agents use bridges more, but it would be nice to have.

I am primarily a C++ dev, and have started looking through to find where the NavArea application should be occurring but what I was hoping for is a solution that doesn't involve me adding in a plugin to overload a engine class or changing the unreal engine code directly as this is not a massive priority for us atm.

Product Version: UE 4.11
Tags:
more ▼

asked May 26 '16 at 12:37 AM in Bug Reports

avatar image

Wolflight
46 4 7 8

avatar image Sean L ♦♦ STAFF May 26 '16 at 02:47 PM

Hello Wolflight,

  • What settings did you alter in the Project Settings->Navigation Mesh section?

  • Have you been able to reproduce this in a clean project?

  • Is this only occurring with the one particular mesh?

avatar image Wolflight May 27 '16 at 03:51 AM

Nothing I would have expected to effect this, but my change list has

bSortNavigationAreasByCost=True

-SupportedAgents=(Name="Default",Color=(B=0,G=255,R=140,A=164),DefaultQueryExtent=(X=50.000000,Y=50.000000,Z=250.000000),NavigationDataClassName=/Script/Engine.RecastNavMesh,AgentRadius=15.000000,AgentHeight=150.000000,AgentStepHeight=-1.000000,NavWalkingSearchHeightScale=15.000000,PreferredNavData=Class'/Script/Engine.RecastNavMesh',bCanCrouch=False,bCanJump=False,bCanWalk=False,bCanSwim=False,bCanFly=False)

+SupportedAgents=(Name="Default",Color=(B=0,G=255,R=140,A=164),DefaultQueryExtent=(X=50.000000,Y=50.000000,Z=250.000000),NavigationDataClassName=/Script/Engine.RecastNavMesh,AgentRadius=20.000000,AgentHeight=150.000000,AgentStepHeight=-1.000000,NavWalkingSearchHeightScale=15.000000,PreferredNavData=Class'/Script/Engine.RecastNavMesh',bCanCrouch=False,bCanJump=False,bCanWalk=False,bCanSwim=False,bCanFly=False)

was really just tweaks so that our agents wouldn't walk quite so close to the edges of our bridges/walkways, and wherever we had a bridge transition into a swingbridge/walkway that the clearance underneath the bridge could fit the agent. I have a separate project running for testing shaders which I imported some fbx files into and set up the same as above and had the exact same issue again, ( beware of this problem https://answers.unrealengine.com/questions/186956/static-mesh-missing-nav-collision.html I lost an hour or two thinking I had some modification causing this -_-) This had no changes to the Project settings for the navigation.

alt text

navarea2.0.png (949.0 kB)
avatar image Sean L ♦♦ STAFF May 27 '16 at 01:35 PM

Thank you for the information. Based on what you're saying, I think the best course of action would be to provide the static mesh asset that you are using so that I can spend some time attempting to determine if there is an issue. If you could, please zip up the affected mesh(es) and provide a link to Dropbox where I can download them. You can PM me a link on the forums: https://forums.unrealengine.com/member.php?160394-Sean-Flint

avatar image Sean L ♦♦ STAFF Jun 01 '16 at 08:08 PM

I'm currently investigating this issue, and will respond back as soon as I have new information. Thank you for providing the assets.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Wolflight,

I've looked into the issue, and I've found that altering the settings in Project Settings->Nav Mesh, such as Agent Height, Agent Radius, etc, allowed me to get a usable Nav Mesh on the objects.

Are you still experiencing this issue? If so, could you try playing with some of those values to see if you can get the Nav Mesh to generate on your meshes?

Also, keep in mind that the visual representation of the Nav Mesh isn't always perfect, which could mean that the Nav Mesh will work during the game even if it does not display as expected in the viewport.

Let me know if any of this helps.

more ▼

answered Jun 10 '16 at 03:28 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question