x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Vive HMD is blank in VR preview

As the title suggests, I have a Vive and would like to develop for it. Unfortunately, when I click "VR Preview" in UE4 (I've tried 4.12, 4.11, and 4.10) nothing shows in the Vive's HMD. A window does appear on my main monitor showing what I assume is the view that one of the eyes in the HMD should see. The window that appears: alt text (The vive changed position a bit when I tried to get the picture. it normally is the correct height in game)

From what I've seen in this window before, the tracking works on the HMD and both controllers. The Vive itself displays either a black void or the main SteamVR hub with the VR preview running. I've tried everything I can think of to fix this, but haven't found anything to make it work. I do have the Vive plugin in UE4 enabled as well.

And to cover all my bases; here is the project I used to capture the picture from above. I have 3 GTX 980 cards in my PC and I know 100% that it plays games so it works. Not sure if this is needed, but to get the Vive to work properly in general, I must unplug every other screen from my PC before launching Steam VR (If you have a fix for that I'd gladly accept it.). I really want to use UE4 to make games for the Vive but this is holding me back from that. All help is greatly appreciated!

Product Version: UE 4.12 Preview
Tags:
more ▼

asked May 27 '16 at 04:35 AM in VR

avatar image

catellus
13 3 9 10

avatar image GValbert Aug 30 '16 at 09:29 PM

Hi, Quite frustrating indeed. I'm experiencing the exact same issue with mine. Vive and Steam VR are perfectly functional but for some reason Ue4 VR preview takes me to the SteamVR hub. Please could someone help? Thanks in advance.

avatar image sranck Aug 30 '16 at 11:05 PM

Hey catellus,

FWIW, I grabbed your project and tried it without modification, and it works fine for me. I see the world in the Vive's HMD, and I can move around the cone and box which are attached to the controllers. I don't have 3 GTX 980 cards, but do have 1 GTX 980 with 3 monitors plus the Vive, and it works fine. You may want to try removing 2 of your GTX 980 cards just to see what happens. But as far as your UE4 project goes, it works.

avatar image guyal Sep 01 '16 at 12:52 AM

I had the same issue, which I solved today, with this different: - 1 GTX 1080 - Unreal and Unity Editors both running at same time I was checking some small Vive demos in Unity, but then stopped doing that, and tried an Unreal hello Vive. Only blank screens, on several days. Today, I rebooted, left Unity closed, and Unreal VR Preview works as expected, the in-editor pop-up window and in the Vive.

So I don't know the hard answer, but my experience is consistent with some other software "blocking" Unreal graphically. Are you running something else that accesses the Vive, besides SteamVR, e.g. Revive?

Alternately, sranck's idea makes sense too :)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

hey,I got the question. and please you tell me how to fix the problem?

more ▼

answered Sep 06 '16 at 07:50 AM

avatar image

andrewsams
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question