x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Game Center support skips Startup Movies

We have three startup movies in our iOS game, and the second one get's skipped because of logging in to Game Center on the device.

This doesn't happen on Android, which waits until the movies are finished before trying to login. Can this be fixed? There's no work around at the moment.

Product Version: UE 4.11
Tags:
more ▼

asked May 31 '16 at 02:16 PM in Bug Reports

avatar image

TheJamsh
815 60 97 140

avatar image Samantha Sutton ♦♦ STAFF Jun 06 '16 at 07:45 PM

Jamsh,

Thanks for bringing this to our attention. I'm investigating this further at this time. When you're playing your game on your iOS device, does the first and third movie play without a problem, and only two is skipped or is it both two and three that are being skipped? How long are your clips? Do you have them set to skippable?

Thanks!

avatar image TheJamsh Jun 09 '16 at 03:49 PM

Hey Samantha, we only have two movies at the mo but we will shortly have three!

The first video is the unreal one, the second is a similar one for our studio logo, the third (will be) a similar one for the logo of the game.

The first video plays a bit strangely, we get a bit of flickering, and sometimes it makes it to the start of the second video but sometimes it just skips straight into the game. It doesn't seem to happen if the user is already logged in..

We're doing our logging in/our the same way that Match3 does it, if that's any help!

avatar image Samantha Sutton ♦♦ STAFF Jun 10 '16 at 05:13 PM

So I've been looking into this for a bit now and I have yet to reproduce this issue. I added start up movies that were not skippable to the Unreal Match 3 project and they all ran through without any skipping involved. Have you tried in a newer version of the engine yet? Have you made sure that you made the selection for the movies to NOT be skippable?

Good luck. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey TheJamsh,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Jun 14 '16 at 06:01 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question