x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Stats not enabled in Test build, docs say they should be

Hi,

Latest version of Build.h : https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Source/Runtime/Core/Public/Misc/Build.h

Line 196 in Test config, it has "#define STATS 0", but in the docs here:

https://docs.unrealengine.com/latest/INT/Programming/Development/CompilingProjects/

It describes Test as:

"This configuration is the Shipping configuration, but with some console commands, stats, and profiling tools enabled"

One or the other of these is wrong, but which?

Cheers, Ben

Product Version: UE 4.11
Tags:
more ▼

asked Jun 01 '16 at 09:32 AM in Bug Reports

avatar image

Bennicus
28 4 8 11

avatar image Tim C ♦♦ STAFF Jun 03 '16 at 08:15 PM

Hi Ben,

I took a look at the source code you mentioned and saw what you described there. However, when I built a project using the Test Solution Configuration, I was able to bring up the console in the game and run various stat commands. Are you unable to run these commands when you build in the Test Solution Configuration?

Tim

avatar image Bennicus Jun 13 '16 at 05:09 PM

Hi Tim, Yeah in test builds of our game none of the stat commands do anything unless we go and change that #define in Build.h!

Ben

avatar image Tim C ♦♦ STAFF Jun 13 '16 at 09:22 PM

Hi Ben,

I have not yet seen any stat commands not work for me in a Test build of a project. Do you see this happen in a new project as well, or only in your own project? What are the exact stat commands that you are using that are not working?

Tim

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Ben,

We have not heard back from you for a few days. Do you still need help with this issue? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment with more information at any time to re-open the post.

Tim

more ▼

answered Jun 12 '16 at 01:09 PM

avatar image PerilousOrbit Jul 11 '16 at 01:40 AM

Hi Tim,

Thanks for your attention on this issue. I haven't been able to get "stat game" "stat startfile" or even "stat info" to be recognized in Test builds. Are those expected to work?

avatar image Tim C ♦♦ STAFF Jul 19 '16 at 05:19 PM

Hi PerilousOrbit,

Sorry for the delay in getting back to you. I checked on what stat commands were expected to work in a Test build. The only ones that should work are Stat FPS and Stat UNIT (ironically, these were the two that I was testing earlier). The rest of the Stat commands are not intended to be included in Test builds.

Tim

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question