x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Flickering Material on opengl4+tesselation on Linux

Hi,

I wanted to make a water material with dynamic displacement in UE4 on Linux. But as soon as i am turning tesselation on (both, flat and PN Triangles) the material start to flicker heavily. This only happens in the translucent mode. Not in masked or opaque mode. The translucent materials are okay if i have no tesselation enabled.

Some technical details:

  • UE4.11

  • Nvidia driver 364.19-3

  • Arch Linux

  • started with primusrun (I am on a Laptop) and -opengl4

I attached a picture with the flickering, the states of what is white and what is black change really fast :D

-thanks for any help/fixes if you need more information please comment!

-siebencorgie

alt text

Product Version: UE 4.11
Tags:
more ▼

asked Jun 01 '16 at 02:54 PM in Bug Reports

avatar image

siebencorgie
224 22 26 30

avatar image Doug E ♦♦ STAFF Jun 01 '16 at 05:51 PM

Hey siebencorgie-

Can you add a screenshot of how your material is setup? I tried adding a black base color and a constant value (1) connected to the Refraction pin. The details panel was setup to match what is shown in your screenshot, however the preview was a solid black rather than showing any flickering. Let me know if there is something I may have missed in my setup.

avatar image siebencorgie Jun 01 '16 at 06:44 PM

hi, I'll add a screenshot of the material. Maybe it has something to do with primusrun.

alt text

avatar image worldlearner0411 Jun 04 '16 at 05:40 PM

Hello, I'm on my phone so I have to keep this short :) There are two things that come to mind that you can try. First, turn your "Max Displacement" setting up. The flickering that your getting....is it your entire water materiel or is it distance based? For example, with landscape tessellation having "Max Diplacement" turned down can give flickering close to the camera. The second thing I would try is using just a single constant for your opacity. I have also had bizarre things happen with normals. For example I have had situations where too strong of a normal map can make it so that even turning the normal intensity to zero does not prevent the normal from displaying. When in doubt go back to the basics. Try just adding a single normal map instead of your alpha setup.

avatar image worldlearner0411 Jun 04 '16 at 05:42 PM

Of course there are other things it could be....I would always first suspect an issue in the material.

avatar image siebencorgie Jun 04 '16 at 06:41 PM

Hi, Thanks for the suggestions. I tried both of them. Sadly without success. I think it wight be a problem with the fact that i am running on primusrun. When I have access to a normal desktop PC I'll try it without primusrun.

avatar image Doug E ♦♦ STAFF Jun 06 '16 at 04:42 PM

Hey siebencorgie-

I believe this may be related to the normal you're using. I followed the setup based on your screenshot and do not see any flickering in the preview window, the main difference being that I used the T_Brick_Clay_Old_N for the normal (not sure what your normal is). If you have starter content in the project, can you let me know if using this file produces the same flickering for you? If you don't have starter content, you can add it by using Add New in the content browser and selecting "Add New Feature or Content Pack" and selecting Starter Content under the Content Packs tab.

avatar image siebencorgie Jun 07 '16 at 06:08 PM

Hi, when using the same texture I get the strange bugs as well. I created a new material. When I change the mode to translucent and add tesselation the bugs are there as well (without any actual nodes in the material graph). Do you have the option to test UE4 on Linux with an Intel - Nvidia hybrid laptop with Bumblebee installed? I believe its because I use Bumblebee (more exactly primusrun) to work with the engine.

-siebencorgie

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey siebencorgie-

I apologize for the delayed response. I missed that you originally mentioned that you were using Shader Model 5 (openGL4). When I launch a project with this setting I was able to repro the "disco" effect in the material editor. This has been bugged as UE-32865.

Cheers

Doug Wilson

more ▼

answered Jul 06 '16 at 08:36 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question