x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

UE4 on Wayland Linux

Hi,

what is the stat of UE4 on Wayland? If I start it there, the courser always moves out of the main window. (in PIE and normal editor view when rotating the camera). Will this be fixed any time soon, or is this just a bug on my system?

thanks for any answer!

-siebencorgie

Product Version: UE 4.12
Tags:
more ▼

asked Jun 02 '16 at 06:09 PM in Bug Reports

avatar image

siebencorgie
224 22 26 30

avatar image Doug E ♦♦ STAFF Jun 02 '16 at 07:27 PM

Hey siebencorige-

Just to confirm, you're saying that when playing or rotating the camera in the editor that the mouse is not locked to the viewport, correct? Did you have the same issue with 4.11.2 or is this behavior something new that you're seeing in 4.12? Let me know if there is any additional information you can think of that would help us investigate this issue.

avatar image siebencorgie Jun 12 '16 at 06:44 PM

Hi, I got a Nvidia driver update on Friday, the editor works now. I'll post the version as answer to the question.

avatar image siebencorgie Jun 02 '16 at 07:59 PM

That is correct, the mouse is not locked to the viewport. On UE4.11.2 it always crashes my Wayland session when loading a project. I don't know why. I think the problem occurs because the method used to bind the courser to the viewport only works on X11. But that is only a guess.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

The problem fixed itself. I got an driver update for Nvidia ( 364.19-5 ). The editor works perfectly now! Much smoother experience as on X-Window System :D. System: GTX 860m, I7 4710 HQ (Laptop), Arch Linux.

Thanks for the help!

more ▼

answered Jun 12 '16 at 06:48 PM

avatar image

siebencorgie
224 22 26 30

avatar image siebencorgie Jun 18 '16 at 06:11 PM

I have to correct my answer. The editor worked good for the past days, however, the problem occurs again. I think it might be a xwayland problem. However. i'll continue to use UE4 under Xorg and look for any improvements under Wayland from time to time.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question