x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.12 bad performance

Just migrated my game from 4.11 to 4.12 and I'm experiencing some bad performance during gameplay on the editor compared on how the game runs on 4.11 not only the framerate is lower but choppy too (It has a lot of peaks on the graph during gameplay)

I tried to find what could have changed but I couldn’t identify the problem.

(I haven’t packaged the project to test if the problem is only on the editor)

Product Version: UE 4.12
Tags:
more ▼

asked Jun 02 '16 at 07:01 PM in Bug Reports

avatar image

gustavorios2
218 18 24 33

avatar image DJoExe Jun 02 '16 at 07:42 PM

Same problem here, looks like a occlusion culling problem, because in 4.11, I had a lot of meshes that disapeared close to the edge of the viewport, but in 4.12, no more poping meshes issue, but again I had way more FPS than in 4.12.

Need help as well

avatar image Adam Davis STAFF Jun 02 '16 at 07:55 PM

Hi gustavorios2,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • How large of a discrepency are you seeing between 4.11 and 4.12?

  • What steps can I take to reproduce this on my end?

  • Can you post your dxdiag here so I can take a look?

avatar image gustavorios2 Jun 02 '16 at 08:29 PM

Hi Adam, thanks for the quick reply.

I don’t think you will be able to see any difference on a empty project. This is probably noticeable on a big project.

Well its a big difference on performance.

I attached 2 screenshots for you to see the same level on 4.11 and 4.12

ps1: In this screenshot in 4.12 the lightmap build is missing. I tested before with the lightmap but the framerate still very low compared with 4.11

ps2: the peaks on the graph are probably noise of the screencapturing

I have a GTX 970, i7-4790 CPU @ 3.60GHz, 32 GB ram, windows 10

alt text alt text

Yes my game probably could use some optimization and I will do that. What I think is strange is that the same game version have so different framerates between 4.11 and 4.12. I'm updating this project for about 18 months and never noticed such difference

411_b.jpg (173.5 kB)
412_b.jpg (209.2 kB)
avatar image Adam Davis STAFF Jun 02 '16 at 08:57 PM

Do you have a lightmass importance volume in the level? Additionally, is this a c++ project or blueprints? Do you see any difference in a clean level?

avatar image gustavorios2 Jun 03 '16 at 12:01 AM

this is a blueprint project and "openworld", with a level with many sublevels yes I have lightmass importance volumes

here a test on a single sublevel very good performance (with a strange noise on 4.12)

alt text

411_c.jpg (207.8 kB)
avatar image DJoExe Jun 03 '16 at 02:07 AM

On my side here are some stats from the same scene on each version of the engine.

GPU : GTX 970 CPU : i7 2600k Ram : 16gb OS : Win 7 alt text

alt text

alt text

alt text

avatar image gustavorios2 Jun 03 '16 at 02:40 AM

thanks DJoExe looks like its the same issue

avatar image Adam Davis STAFF Jun 03 '16 at 01:44 PM

Are you streaming levels or do you have all levels constantly loaded? Are you using the world composition browser? Have you made sure all levels have had lighting built and saved or just the persistent level? Additionally, have you run through our lighting and swarm agent troubleshooting guides to see if they resolve your error?

https://wiki.unrealengine.com/LightingTroubleshootingGuide

https://wiki.unrealengine.com/Swarm_Agent_Troubleshooting

avatar image gustavorios2 Jun 03 '16 at 06:17 PM

its a main empty level with 70 sublevels. they are always loaded and I'm not using streaming volumes. no I'm not using world composition. yes I've read the articles before, actually I'm not having any lightmap problem. All those 70 levels build with 0 error.

the game is running perfectly fine on 4.11 I'm just reporting that the same project get really slow on 4.12

I just baked light on 4.11 and its running solid and noiseless at 99 fps. when I had the project with baked lights (in 4.12) it was running at 40 / 60 fps and full of peaks

avatar image gustavorios2 Jun 03 '16 at 07:32 PM

I've tried to do a CPU test booth instances are running at 50% resolution, all effects on lowest settings and unlit mode so its about a 19 fps difference on the cpu test

https://www.youtube.com/watch?v=8YQomyUsV0A&feature=youtu.be

avatar image DJoExe Jun 03 '16 at 08:44 PM

Another thing I found considering the performance issue. Looks like it is also related to the shadows rendering. While the engine seems to manage occlusion culling differently from 4.11.2, it also render all the point light that are casting shadows, even if they are completely culled by walls.

alt text

alt text

avatar image fszczemton Jun 04 '16 at 12:57 PM

In my case fps fell from 60 to 45 on a empty template project.

avatar image Adam Davis STAFF Jun 06 '16 at 03:42 PM

Does anyone have a sample project this is occurring in I can take a look at or steps I can take to reproduce this on my end?

avatar image gustavorios2 Jun 06 '16 at 10:42 PM

tested in an empty project; high polycount/occlusion, lights and no success =(

Many new things in 4.12 were implemented to archieve high quality reflections like, “High Precision Static Mesh Vertex Normal and Tangent Encoding” I wonder if any of these were enabled by default on 4.12 and slowed things down

the new sequencer could in any way (even if its not being used) interfere in the performance?

avatar image gustavorios2 Jun 06 '16 at 11:39 PM

Good news! Disabling two particle systems that was widely used in many sublevels, unreal 4.12 reached the same framerate from 4.11 (actually 3-4 frames higher) :) I'll try to investigate further what changed in 4.12 particles.

avatar image gustavorios2 Jun 07 '16 at 04:56 AM

I managed to reproduce the problem on a new project

the problem is that I was using the distance parameter on the particles. it works in 4.11, but in 4.12 don't.

alt text

I fixed it enabling LODS on the particles

I attached a sample project in this message showing the bug.

Sorry for making this a big deal. I was worried to be stuck in 4.11 forever =P

link text

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

HI gustavarios2,

I'm happy to hear you found a solution to the error you were experiencing. I will mark this as answered for tracking purposes. If this occurs again after your fix, please feel free to post back here and I'll be happy to take another look.

more ▼

answered Jun 07 '16 at 02:35 PM

avatar image gustavorios2 Jun 07 '16 at 10:01 PM

Thank you Adam for your support!

avatar image gustavorios2 Jun 08 '16 at 12:51 PM

One more thing: you think this have a chance to be fixed? for some reason the distance property works better than lods for disabling the particles. You can easily see on the sample project I've sent that it stopped working in 4.12

https://answers.unrealengine.com/storage/attachments/93662-particlesperformance.zip

avatar image Adam Davis STAFF Jun 08 '16 at 06:26 PM

The fix you provided above is the correct method to use when utilizing max draw distance. It requires LODs to be enabled to work correctly, otherwise it will not work. This is not a bug, it is simply the correct method to use when attempting to use max draw distance.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question