x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error on 4.12 github build: Error: CDO Constructor (PaperSprite): Failed to find /Paper2D/MaskedUnlitSpriteMaterial

When converting my project to 4.12 from 4.11, I of course updated the plugins that I've been using for the project, and whenever I launch it, I get the following error:

 [2016.06.04-22.10.37:142][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/MaskedUnlitSpriteMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:142][  0]LogLinker:Warning: Can't find file '/Paper2D/MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/MaskedUnlitSpriteMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:142][  0]LogLinker:Warning: Can't find file '/Paper2D/MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]LogUObjectGlobals:Warning: Failed to find object 'MaterialInterface /Paper2D/MaskedUnlitSpriteMaterial.MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]Error: CDO Constructor (PaperSprite): Failed to find /Paper2D/MaskedUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:142][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/OpaqueUnlitSpriteMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:142][  0]LogLinker:Warning: Can't find file '/Paper2D/OpaqueUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/OpaqueUnlitSpriteMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:142][  0]LogLinker:Warning: Can't find file '/Paper2D/OpaqueUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]LogUObjectGlobals:Warning: Failed to find object 'MaterialInterface /Paper2D/OpaqueUnlitSpriteMaterial.OpaqueUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]Error: CDO Constructor (PaperSprite): Failed to find /Paper2D/OpaqueUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:142][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/MaskedUnlitSpriteMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:142][  0]LogLinker:Warning: Can't find file '/Paper2D/MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]LogUObjectGlobals:Warning: Failed to find object 'MaterialInterface /Paper2D/MaskedUnlitSpriteMaterial.MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:142][  0]Error: CDO Constructor (PaperFlipbook): Failed to find /Paper2D/MaskedUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:143][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/DefaultPaperTerrainMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:143][  0]LogLinker:Warning: Can't find file '/Paper2D/DefaultPaperTerrainMaterial'
 [2016.06.04-22.10.37:143][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/DefaultPaperTerrainMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:143][  0]LogLinker:Warning: Can't find file '/Paper2D/DefaultPaperTerrainMaterial'
 [2016.06.04-22.10.37:143][  0]LogUObjectGlobals:Warning: Failed to find object 'PaperTerrainMaterial /Paper2D/DefaultPaperTerrainMaterial.DefaultPaperTerrainMaterial'
 [2016.06.04-22.10.37:143][  0]Error: CDO Constructor (PaperTerrainComponent): Failed to find /Paper2D/DefaultPaperTerrainMaterial
 
 [2016.06.04-22.10.37:143][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/MaskedUnlitSpriteMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:143][  0]LogLinker:Warning: Can't find file '/Paper2D/MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:143][  0]LogUObjectGlobals:Warning: Failed to find object 'MaterialInterface /Paper2D/MaskedUnlitSpriteMaterial.MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:143][  0]Error: CDO Constructor (PaperTileMap): Failed to find /Paper2D/MaskedUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:143][  0]LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Paper2D/MaskedUnlitSpriteMaterial' is not a standard unreal filename or a long path name. Reason: Path does not start with a valid root. Path must begin with: '/Engine/', '/Game/', '/Config/', '/Script/', or '/Temp/'
 [2016.06.04-22.10.37:143][  0]LogLinker:Warning: Can't find file '/Paper2D/MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:143][  0]LogUObjectGlobals:Warning: Failed to find object 'MaterialInterface /Paper2D/MaskedUnlitSpriteMaterial.MaskedUnlitSpriteMaterial'
 [2016.06.04-22.10.37:143][  0]Error: CDO Constructor (PaperTileMapComponent): Failed to find /Paper2D/MaskedUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:143][  0]LogUObjectBase:Warning: -------------- Default Property warnings and errors:
 [2016.06.04-22.10.37:143][  0]LogUObjectBase:Warning: Error: CDO Constructor (PaperSprite): Failed to find /Paper2D/MaskedUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:143][  0]LogUObjectBase:Warning: Error: CDO Constructor (PaperSprite): Failed to find /Paper2D/OpaqueUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:143][  0]LogUObjectBase:Warning: Error: CDO Constructor (PaperFlipbook): Failed to find /Paper2D/MaskedUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:143][  0]LogUObjectBase:Warning: Error: CDO Constructor (PaperTerrainComponent): Failed to find /Paper2D/DefaultPaperTerrainMaterial
 
 [2016.06.04-22.10.37:143][  0]LogUObjectBase:Warning: Error: CDO Constructor (PaperTileMap): Failed to find /Paper2D/MaskedUnlitSpriteMaterial
 
 [2016.06.04-22.10.37:143][  0]LogUObjectBase:Warning: Error: CDO Constructor (PaperTileMapComponent): Failed to find /Paper2D/MaskedUnlitSpriteMaterial


This is from the log of course. It does show an error dialogue box but it says the same thing, this just has more detail. Oddly enough, this problem only surfaces on the Github branch that I'm compiling from source, but if I launch with the exact same plugins in the 4.12 binary release on the launcher, it works perfectly and has no errors whatsoever. The only information I've been able to find on this exact issue has inconclusive answers and were relatively old. If there's anything I can do to get this working, that would be very helpful.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 05 '16 at 03:46 AM in Bug Reports

avatar image

Zero-Night
86 8 11 20

avatar image Doug E ♦♦ STAFF Jun 06 '16 at 03:16 PM

Hey Daniel-

Exactly which plugins are you using? Additioinally, I'm unable to find "MaskedUnlitSpriteMaterial" in the documentation, is this the name of a folder in your project? I noticed a few warnings/errors referring to this.

avatar image Zero-Night Jun 07 '16 at 05:41 AM

It's the Advanced Sessions Plugin, at least the one I care the most about getting fixed. There were a few others, but using the individually or all at once doesn't seem to matter it returns the same exact error with the same exact Paper2D files.

"MaskedUnlitSpriteMaterial" isn't my material, upon looking through Paper2D since it came up a lot however I found it in the Paper2D plugin folder. Interestingly enough, no matter what plugin I happened to be using, it was always those same Paper2D materials that weren't able to load, even though my project isn't even using Paper2D (it would even get the Paper2D errors just launching the engine without a project specified).

From the actual editor, these are the error messages it was giving me:

alt text

alt text

alt text

Now I'm not 100% certain if what I did actually fixed this problem or simply stopped it from surfacing. After a sleepless night of trial and error trying to get it working, I may have stumbled across the answer. The plugin's instructions say to place it in the project's plugins folder, but if I place it in the engine's plugins folder before compiling the engine it seems to work.

I may be wrong, but it just seems like a case of a very, very misleading error message. As you can see yourself, it's referencing files that have nothing to do with the plugin whatsoever which lead me to believe it may have been an issue with the Github distribution itself, maybe not downloading some files or something. If you think there may still be a problem underneath all this, I'll be more than happy to help in trying to hunt it down, but at least at first glance it looks like all it needs is a better error saying what went wrong.

error1.png (7.0 kB)
error2.png (19.9 kB)
error3.png (6.5 kB)
avatar image Tim C ♦♦ STAFF Jun 11 '16 at 07:32 PM

Hi Daniel,

I spent some time today trying to reproduce this upgrade issue from 4.11.2 to 4.12.0, and was unable to see the errors that you reported. I located the materials that your logs were indicating were being problematic, but when I was upgrading my project, they did not seem to be causing me any trouble. I did notice that a new version of the Advanced Sessions plugin was made available for 4.12.2 a couple days ago. Do you still have the same trouble with that version of the Engine and plugin?

Do you also see the same issue happen if you create a new project in 4.11 and upgrade it to 4.12 (with or without using the same plugins)?

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Daniel,

We have not heard back from you for a while. Do you still need assistance with this? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment and re-open the post at any time if you need any more help.

Tim

more ▼

answered Aug 08 '16 at 05:43 PM

avatar image Zero-Night Aug 08 '16 at 06:00 PM

Hi Tim,

After working on the project for a while after having the main issue and using the plugin in it, the only conclusion that I can come to is that my suspicions from my last post were correct about it just being a very misleading error message.

By placing the plugin in the project's plugins folder instead of the engine's plugins folder as per the instructions, it actually caused the problem. My suspicion is that even though I was using an unmodified Github build that by not having the plugin in the engine's plugins folder it was somehow causing a problem. The moment I placed the plugin in the Github build's plugins folder and recompiled the engine, everything just started working again. No errors about Paper2D or anything incompatible, it just worked as it was supposed to.

avatar image Tim C ♦♦ STAFF Aug 09 '16 at 09:44 PM

Hi Daniel,

I am glad to hear that you were able to get past this issue. I have still not been able to reproduce the issue with the Advanced Sessions plugin placed in the project's Plugins folder. If you run into this again, please let us know. Alternatively, if you happen to have a new test project where this behavior occurs, would it be possible to get a zipped copy of the project that we could take a look at?

Tim

avatar image 一桶姜山 May 26 '17 at 06:46 AM

Hi Daniel,I've got the same problem,and I placed the plugin in the engine plugins folder before compile the engine as you said,the problem seems solved,but a new problem came up -- I can't package the project. the log is "Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Staging manifest already contains E:\UE4Projects\Multiplayers\MultiPlayers.uproject (or a file that differs in case only)" Could you give me any suggestion please? :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question