x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Starting Packaged game - Dissapears Using oculus

Is 4.12 fully oculus rift compatible?

I have spent the last few days getting everything working in 4.12, and now the packaged game doesn't load first time. It starts to load and disappears. Sometimews it can take 10 or 12 attempts to launch the game.

I had this problem with the 4.10 github build which had the 1.3 oculus sdk, but was fixed in 4.11 when i can converted.

If i unplug oculus, it works first time, and in htc-vive works first time.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 05 '16 at 01:12 PM in Packaging & Deployment

avatar image

MAGtechnologies
73 4 6 9

avatar image Max Heiermann Jun 15 '16 at 08:33 AM

We ran into the exact same problem. Our game worked just fine in 4.11 (Editor and Build). Since we updated the engine to 4.12, VR Preview was greyed out, although the Oculus was ready. The only way to fix this issue was to update the Oculus Tool to the newest Version of Oculus Home. Now we have the same problem as mentioned here. Our build works fine, if Oculus is not connected. But in the moment, Oculus is plugged in, Oculus Home starts simultaneously when testing our build. During the splashscreen the game goes back to Desktop, without any message or crashreport. The problem appeared with 4.12 and neither 4.12.1 nor 4.12.2 fixed it.

We develop and test with Oculus DK2, and unfortunately the current Version of Oculus Home doesn't support it any longer. We actually are thinking about turning our backs to Oculus to produce only for SteamVR in the future. The massive integration of Oculus Home and their policy is no longer sustainable for us.

avatar image MAGtechnologies Jun 15 '16 at 11:38 AM

Thanks for letting me know its not just me with this problem. Hope this can be sorted out ASAP

avatar image gonzaloecu84 Jun 29 '16 at 06:04 PM

Hello. Im having the same problem. Using Unreal Engine 4.12.3 If Oculus is conected the package wont launch. Sometimes it does but ussualy just closes at startup. I created a new project from scratch, packaged and is exactly the same problem.

I have the Oculus CV1.

If you guys find a solution to this problem let me know.

I have a Vive coming next week ill try with that connected and let you know if i have the same issue.

avatar image Max Heiermann Jun 30 '16 at 01:47 PM

We develop with both, Oculus and HTC Vive, and this Problem only exists with Oculus. With HTC Vive our game is playable as smoothly as usual (Editor and Build).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Just to give a quick update. V 4.12.5 seems to have fixed the bug. or maybe the update from oculus run-time that came last week. anyway VR packaged games are working without issue now.

Thanks to all who gave an input or tried to help to fix this issue.

more ▼

answered Jul 24 '16 at 05:48 AM

avatar image

gonzaloecu84
21 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Swilliams,

I've not noticed anything like this with my Retail Kit at my desk. Do you notice the same behavior in a blank project as a test case or is this just happening in your project?

If it's only happening with your project, are you using a source or binary build of the editor?

Thanks!

Tim

more ▼

answered Jun 06 '16 at 08:28 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 877

avatar image MAGtechnologies Jun 06 '16 at 09:33 PM

Hi Tim, I am using the binary 4.12. I do have a little C++ in.

This only happens with my project, I had this problem with a source build of 4.10 which included the 1.3 sdk, and i thought it was that as i moved to the binary 4.11 build and it worked first time fine. I have moved over to the binary 4.12 build and i have the same starting problem i had in the source build of 4.10

It is very strange, it does not crash, it just disappears. It can take many attempts by the time it launches. If i unplug my oculus, it works first time, same is if i use my vive. .

avatar image Tim Hobson ♦♦ STAFF Jun 29 '16 at 08:00 PM

Sorry for the delay. I'm not really sure at this point since I cannot reproduce this in any project I have.

Would you be able to create a new level for your project and package just that level and send to me if it's still doing this disappearing act? If it's happening in the new level and while packaged I can at least see if I see the same results on my end and see if there is some workaround I can find with the packaged version to get it to not disappear, but no definite guarantees though.

Thanks.

avatar image MAGtechnologies Jun 29 '16 at 08:29 PM

Hi Tim, This is urgent for us now as our game is early access on steam. I will PM you.

avatar image NCMcClure Aug 23 '16 at 11:24 PM

I'm using 4.12.5 and everything works perfectly within the editor. However, upon packaging my project I get exactly the problem described above. I get a black screen for a couple seconds and then it crashes with no warning and no crash report. This is really frustrating and I have no idea how to fix this after hours of searching.

If it matters, I'm using a custom source of UE4 with just a few blueprint node additions to add support for detecting the proximity sensor on the Consumer Rift. So nothing major was modified with the engine.

avatar image gonzaloecu84 Aug 24 '16 at 12:20 AM

Hi NCM, Try unplugging your oculus rift and launching the package in normal mode if its still crashing its probably something else since the issue we where having was only triggered when a CV1 was connected and it was random. sometimes it crashed and sometimes it didn't. but as soon as you disconnected the oculus the package ran like a charm. I'm pretty sure this got fixed since i have packaged at least 5 different projects for VR and all work fine now. if the issue persists try packaging a blank project. Hope you get this fixed.

Best regards

Gonzalo

avatar image NCMcClure Aug 25 '16 at 09:29 PM

So after trying to run my packaged game about 3-15 times with the Rift plugged in, it will indeed run as it's supposed to. This is absurd that this has been passed off as fixed. I've tried on two separate computers running 4.12.5 with two different Rifts and I'm getting the exact same result. Has anyone got some sort of solution or suggestion that might mitigate this problem?

avatar image gonzaloecu84 Jun 29 '16 at 08:21 PM

Just wanted to know why is this post marked as solved? im having the exact same issue even with new projects. will really apreciate some input on how to solve this. Thanks in advance

avatar image Tim Hobson ♦♦ STAFF Jun 29 '16 at 08:42 PM

@gonzaloecu84

Posts are marked as resolved when any staff member responds. This leaves it up to the user(s) involved to provide the necessary information to unmark it for the next steps.

I'll extend the same to you. If you have a simple test project (not a full project!) that can reproduce this I can take a look and see if I can work with it or reproduce on my end, but at the moment I cannot reproduce.

avatar image gonzaloecu84 Jun 29 '16 at 11:56 PM

Hi Tim thanks for the quick reply. Actually i have this issue with any project created un 4.12 im attaching the log of a FirstPerson project (nochanges made just the one you get from the presets) the first log is with oculus CV1 plugged in the second one is with oculus unplugged. (as soon as i unplug my oculus from the computer the project launches normally) link text link text

avatar image gonzaloecu84 Jun 29 '16 at 11:58 PM

I forgot to add that when oculus is plugged the project will launch sometimes its really random sometimes after 5 tries or more.

avatar image gonzaloecu84 Jun 30 '16 at 01:01 AM

Adding simple project link for you to download link text

avatar image Tim Hobson ♦♦ STAFF Jun 30 '16 at 03:04 PM

At the moment, I'm getting a black screen and I can still hear sounds and shoot, but not where it disappears to the task bar or anything. Is this what you're seeing on your end?

avatar image gonzaloecu84 Jun 30 '16 at 03:43 PM

Hi Tim. Actually no, when it fails it only starts for 1 or 2 seconds and then it closes without any crash report just disapears back to desktop. When it decides to work it works as intended (video and audio) and it will stay stable untill you close it

avatar image Max Heiermann Jul 01 '16 at 06:51 AM

This is exactly what we are getting as well. Our constellation: We updated Unreal Engine to 4.12. VR Preview was greyed out, until we updated the Oculus Tool to Oculus Home. And since then, we have this issue (no matter if 4.12.0 - 4).

Click on GameX.exe --> Build starts / Oculus Home simultaneously starts -.- --> After 2-4 seconds back to desktop without any crash report. Sometimes (~ 1/10 attempts) it works, but this is random, and after restarting the build, it occurs again. This only happens if Oculus is plugged in, with HTC Vive everything works as intended.

My guess is that there is a conflict between Unreal Engine and Oculus Home, maybe only if an Oculus DK1 or DK2 is connected.

avatar image gonzaloecu84 Jul 02 '16 at 04:32 PM

I'm using oculus cv1 so I can confirm it also happens with cv1

avatar image foxhound101 Feb 02 '17 at 04:43 AM

Was anyone able yo figure out why this error happens.. im getting something similar in 4.14.

Game runs perfect in editor with and without oculus.

As soon as i package the game (both 32 and 64) i get an error(crash) as soon as the "HMD" is activated. This only happens with the oculus plugged in.

Happened on two different machines, with both DK1 and the comercial release.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question