x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unable to package game, failing while serializing maps 4.12

Hi everyone, I am having a problem packaging my game in 4.12. When I click on package for windows 32 bit or 64 bit it begins to save my maps and serialize bulk data. It goes through my 6 maps and then the editor crashes and says I do not have editor symbols for debugging. I then tried to package just one of my maps, it saves and starts packaging with no problem. Has anyone else had this problem? I am trying to figure what went wrong because it worked perfectly in 4.11. I am using a blueprint from a friend for level switching which uses a master level with all the maps together. Does anyone have any idea what is going wrong here? Thank you

My specs are (if it matters) gtx 550 ti i5 2400 16 gb ram 240 gb ssd

This is my development computer I have a much better rig for final building.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 05 '16 at 07:38 PM in Bug Reports

avatar image

Topgear201
21 4 4

avatar image Matthew J Jun 06 '16 at 03:13 PM

Hello Topgear201,

The "editor symbols for debugging" is an option download you can choose for your Binary installation through the launcher. It's useful for debugging your own issues and will allow you to see the crashes that you receive.

Could you download those through the dropdown arrow beside your engine's installation in the Launcher's Library section and then crash again and post the callstack?

If not, and you submitted the crash when you got it, can you give me the Epic ID or Machine ID that shows up whenever you crash so that I can look up the crash and see what kind of information it can give me?

This would be the first step to finding the problem.

avatar image Topgear201 Jun 06 '16 at 06:03 PM

Hi thank you very much for responding I will do so and get back to you as soon as possible

avatar image Topgear201 Jun 06 '16 at 09:30 PM

Hi here is the editor crash report (Please tell me if i need to post the entire stack) Thank you again

MachineId:423C7570447C739C464B759414E77FDD EpicAccountId:0293b29d64fa4b7387f55094579c6957

Fatal error: [File:D:\Build\++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 202] Illegal call to StaticFindObject() while serializing object data!

avatar image Topgear201 Jun 07 '16 at 01:25 AM

Hello again I looked around and figured out a way to package the game by pressing cancel during the saving of my final level. This is very much a work around and would still love to have a fix for this. Thank you again

avatar image Matthew J Jun 07 '16 at 01:51 PM

Thank you for that information. It seems like it won't do alone though as it isn't giving all that much information. Could you please upload the logs from one of your packaging attempts where you don't use that workaround? You can find them in the project's directory under Saved/Logs. Please be sure to attach the entire file, as even seemingly useless parts could matter.

avatar image Topgear201 Jun 07 '16 at 06:47 PM

link text

Quick update. I updated the editor to 4.12.1 and still experiencing the same problem.

avatar image Matthew J Jun 09 '16 at 09:23 PM

Thank you for the logs. From looking up the error message you are receiving, it seems that this always leads to a blueprint referencing something that it shouldn't be. I can't really be more specific without seeing the project itself and going through what it may be, but it should be narrowed down to blueprints that are only being used in that 6th map since it's the only one that is causing these issues.

avatar image Topgear201 Jun 10 '16 at 05:05 AM

Thank you very much for that assessment. I will know look into my blueprint systems that I am using in that level and see what I can do to fix it.

Thank you for helping me out.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Thank you for all your help update 4.13 has fixed the issue.

more ▼

answered Nov 03 '16 at 10:58 PM

avatar image

Topgear201
21 4 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Topgear201,

We have't heard from you in a while. Have you had any luck finding out what is causing your error? In the meantime, I'll be marking this as a temporary answer for tracking purposes.

more ▼

answered Jun 20 '16 at 03:09 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question