x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

CSM for stationary light not working on mobile

Hi,

CSM for stationary light is not working on mobile for me on Galaxy Note 3. Note that the shadows are not visible in editor too if you switch to any mobile preview renderer under settings. It works with SM5 renderer in editor. I've attached the test project.

Thanks for looking into this,

Jiri

Product Version: UE 4.12
Tags:
more ▼

asked Jun 06 '16 at 12:52 PM in Bug Reports

avatar image

Jiri.Dockal
41 3 5 5

avatar image Jiri.Dockal Jun 06 '16 at 01:44 PM

If you add r.AllReceiveDynamicCSM=1 into project DedaultEngine.ini shadows will show properly. However this will force all primitives to receive both CSM and static shadows right?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Jiri,

They are working as I can see, but it looks like one thing is not made clear in the release notes.

  1. In the Project Settings enable Static and CSM Shadowing.

  2. Select the meshes that should receive shadows and in the details panel enable Receive Combined Static and CSM Shadows from Stationary Lights.

  3. Select the Light source and set a value for Dynamic Shadow Distance StationaryLight.

  4. In the Light Source disable Inset Shadow for Movable Objects.

  5. Build Lighting

  6. Mobile Preview/Launch on Device/Package for your device

At this point you should see dynamic shadows for movable objects that have the value set to receive them. For instance, you don't necessarily need to set the value for the actual movable object, but the floor is receiving the dynamic shadow so it needs to make sure it has been enabled to receive the shadow via the flag in its Details panel.

As for r.AllReceiveDynamicCSM the help text from the output log should help explain this. Disabled by default. Enabled renders for all regardless of whether the flag has been manually set.

Which primitives should receive dynamic-only CSM shadows. 0: Only primitives marked bReceiveCSMFromDynamicObjects (default). 1: All primitives

I hope this helps clear up any confusion.

Tim

more ▼

answered Jun 06 '16 at 07:36 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Jiri.Dockal Jun 06 '16 at 07:37 PM

Totaly clear now. Thank you. Jiri

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
more ▼

answered Jul 07 '16 at 03:36 PM

avatar image

iRYO400
35 5 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question