x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Packaged Game Does Not Execute On Other PCs

I packaged a development version game for windows. It runs fine on my development pc. However, if I run it on other's pc, it always shows the 0xc000007b error. I've installed the prerequisite exe file (UE4/Engine/Extras/Redist/en-us/UE4PrereqSetup.msi/exe) on the second pc, but nothing changed.

Could anyone tell me why?

alt text

Product Version: UE 4.11
Tags:
error.jpg (52.2 kB)
more ▼

asked Jun 06 '16 at 03:20 PM in Packaging & Deployment

avatar image

FarzadMoshiri
71 2 4 6

avatar image Rudy Q ♦♦ STAFF Jun 07 '16 at 03:58 PM

Hello FarzadMoshiri,

I have a couple of questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. Could you provide a detailed list of steps to reproduce this issue on our end?

avatar image Rudy Q ♦♦ STAFF Jun 10 '16 at 07:02 PM

Hello FarzadMoshiri,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

avatar image FarzadMoshiri Jun 10 '16 at 07:45 PM

Hello Rudy

My issue isn't resolved yet. I'm not sure what kind of info is needed. I just can't run any packaged project on my laptop. (They run correctly on the PC I packaged the project on) Each time the same error shows up. (The error's mentioned above)

avatar image Rudy Q ♦♦ STAFF Jun 10 '16 at 07:56 PM

It sounds like you are packaging them project out on your PC and then moving them to your laptop. Is this correct? If you package the project out on your laptop and then attempt to open them, do you still get the same error?

avatar image FarzadMoshiri Jun 11 '16 at 02:43 PM

Yes, that's correct. I haven't installed UE4 on my laptop intentionally; since my possible future clients don't have UE4 and the prerequisites installed on their PCs.

" I need to find out what software prerequisites are there to run an EXE file, packaged in UE4 " That's it :)

Thank you

avatar image FarzadMoshiri Jun 13 '16 at 05:25 AM

Hi there

Any responses ... any guidelines? :)

avatar image Rudy Q ♦♦ STAFF Jun 13 '16 at 02:42 PM

Hello FarzadMoshiri,

I have another quick question for you. What are the two OSs that are being run on the two PCs? Is it possible that you are packaging for windows 64 bit and the other PC is 32 bit?

avatar image FarzadMoshiri Jun 13 '16 at 02:58 PM

Hello Rudy,

The operating system for the both PCs is Windows 10 64bit, and the project's packaged for Windows 64. So ... no, the issue couldn't be here.

Thank you

avatar image Rudy Q ♦♦ STAFF Jun 14 '16 at 07:33 PM

Hello FarzadMoshiri,

If you package out a clean project and try to open it up on the other PC does this work for you? If you still receive this error, would it be possible for you to provide the sample project via a zip file on dropbox or google drive?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Dear Rudy,

After testing couple of scenes, the problem's resolved now. Apparently my laptop only executes 32-bit packages, although the operating system is 64-bit ! Due to lack of technical information in this field, that sounds quite odd to me ... Anyway now I've got the idea to package my projects for "Windows 32-bit" in order to execute correctly on my laptop.

Thank you for your support

more ▼

answered Jun 19 '16 at 11:50 PM

avatar image

FarzadMoshiri
71 2 4 6

avatar image Rudy Q ♦♦ STAFF Jun 20 '16 at 05:18 PM

Hello FarzadMoshiri,

Thank you for the additional information. I am happy to hear that you have found a workaround for this issue. I will be marking your last comment as the answer to this thread. If the issue returns and you are able to provide additional information to reproduce this issue on this end. please feel free to reopen this issue.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question