x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Editor crashes after upgrade to 4.12

After I updated my project to 4.12 my editor keeps on crashing and will not open. I managed to update my c++ code and got it to compile for 4.12 in VS, but then it keeps crashing when I try to open in the editor.

The following is the message I get in the crash reporter:

Ensure condition failed: this->IsBound() [File:c:\program files (x86)\epic games\4.12\engine\source\runtime\core\public\delegates\DelegateSignatureImpl_Variadics.inl] [Line: 1042] Unable to bind delegate to 'balloutEndOverlap' (function might not be marked as a UFUNCTION)

UE4Editor_CoreUObject!UObjectBaseUtility::GetOutermost() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectbaseutility.cpp:121] UE4Editor_UnrealEd!ObjectTools::IsObjectBrowsable() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\objecttools.cpp:85] UE4Editor_UnrealEd!PackageTools::GetFilteredPackageList() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\packagetools.cpp:67] UE4Editor_UnrealEd!PackageTools::CheckForReferencesToExternalPackages() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\packagetools.cpp:536] UE4Editor_UnrealEd!UEditorEngine::PackageUsingExternalObjects() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\playlevel.cpp:3567] UE4Editor_UnrealEd!UEditorEngine::Map_Check() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\editorserver.cpp:3845] UE4Editor_UnrealEd!UEditorEngine::HandleMapCommand() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\editorserver.cpp:5980] UE4Editor_UnrealEd!UEditorEngine::Exec() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\editorserver.cpp:5477] UE4Editor_UnrealEd!UUnrealEdEngine::Exec() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\unrealedsrv.cpp:744] UE4Editor_UnrealEd!FEditorFileUtils::LoadMap() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\filehelpers.cpp:2177] UE4Editor_UnrealEd!FEditorFileUtils::LoadDefaultMapAtStartup() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\filehelpers.cpp:3349] UE4Editor_UnrealEd!FUnrealEdMisc::OnInit() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\unrealedmisc.cpp:300] UE4Editor_UnrealEd!EditorInit() [d:\build++ue4+release-4.12+compile\sync\engine\source\editor\unrealed\private\unrealed.cpp:89] UE4Editor!GuardedMain() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\launch\private\launch.cpp:137] UE4Editor!GuardedMainWrapper() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:200] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

The following is the relevant code for where it says "Unable to bind delegate to 'balloutEndOverlap' (function might not be marked as a UFUNCTION)" :

In .h:

 private:
 
     UFUNCTION()
         void balloutEndOverlap(class UPrimitiveComponent* ThisComp, class AActor* OtherActor, class UPrimitiveComponent* OtherComp,
             int32 OtherBodyIndex);

In .cpp:

 void AballOutClass::balloutEndOverlap(class UPrimitiveComponent* ThisComp, class AActor* OtherActor, class UPrimitiveComponent* OtherComp,
     int32 OtherBodyIndex)
 {
     int32 testInt = 15;
 }

In constructor:

 ballOutCollision->OnComponentEndOverlap.AddDynamic(this, &AballOutClass::balloutEndOverlap);

I should mention that I already tried to completely comment out all the relevant code for the ballEndOverlap function, including the constructor statement, but it doesn't make a difference and it just gives the same crash error for another End/Begin Overlap delegate function, throughout my whole project and I have several places throughout other classes where I'm using delegates for End/Begin Overlap functions.

I upgraded my project from version 4.11.2

Product Version: UE 4.12
Tags:
more ▼

asked Jun 06 '16 at 06:38 PM in Using UE4

avatar image

Alieninsane
18 4 7 11

avatar image Alieninsane Jun 07 '16 at 02:05 PM

Just wanted to bump this. I decided to do a test by removing all of my content data from the content folder to check if there are any blueprints or levels that are causing this crash. After removing all the content, the editor ran so I decided to put back blueprints one by one to check if there's a specific blueprint that's causing the crash. If I do this and make any change to any blueprint and try to compile, the project will crash. If I try to add a new C++ class and try to compile it will still crash. It always gives the same crash report though.

avatar image Alieninsane Jun 15 '16 at 10:08 AM

Wanted to bump this again. I tried again after updating the engine to the latest patch (4.12.2) and I still get the same crash. Even if I delete all my content, I'll be able to enter the editor but if I try to create a new class, it crashes again.

avatar image Alieninsane Jul 01 '16 at 03:30 AM

Just wanted to bump this again as I still get the same crash after updating to patch 4.12.4. At this point I've begun working on rebuilding my whole project from scratch using the 4.11 latest version as a reference point but this is a very slow process as there are a lot of dependencies I have to consider. I would like to know if anyone else is facing this issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question