x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Animations not saving to project

For some weird reason UE4 keeps deleting my animations every time I close the editor, and none of the animations show up in the standalone game. I do save them before I close it. I keep having to reimport the .fbx so I can at least see the animations when I play the game in-editor. This only started happening once I updated to 12.0, so this might be a bug? Regardless, if anyone can help with this, that would be great. Cheers.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 06 '16 at 10:03 PM in Bug Reports

avatar image

ViddyXD
8 2 3 6

avatar image ViddyXD Jun 07 '16 at 07:40 AM

Just used UE4.11.2 and it worked fine. So it's definitely UE4.12 doing this.

avatar image Matt.Williams Jun 08 '16 at 05:54 PM

Hi ViddyXD,

I'm unable to reproduce this on my end. This may be an issue with how the engine is handling your files. I'm going to ask that you to send your fbx files to me, but also include a screenshot of your import settings along with detailed steps on essentially every action you take from import to closing/re-opening the editor.

I don't know if you're exporting your animations separately from your skeletal mesh, but can you send me all relevant FBX files? You can PM me a download link on the forums.

-Matt W.

avatar image Matt.Williams Jun 15 '16 at 05:55 PM

Are you saving in Persona? Are you sure that you have the animation selected and not the Mesh/Skeleton in the top right of Persona?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi ViddyXD,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

-Matt W.

more ▼

answered Jun 20 '16 at 08:24 PM

avatar image Matt.Williams Jun 21 '16 at 03:17 PM

Found this and entered UE-32283 based on this user's description: https://answers.unrealengine.com/questions/439576/imported-animations-not-saving.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I just encountered the same problem. i fixed it by saving the individual animations in the asset browser or saving all assets int he asset browser. if one doesn't work try the other! i hope this helped!

more ▼

answered Jun 13 '16 at 05:30 PM

avatar image

TenashiousG
6 1 2 2

avatar image AlexZ005 Jun 26 '16 at 06:16 PM

Well, indeed, had the same problem with 4.12.3-3013449. Thanks for the temporary solution, this helped, just had to create 'Animation Blueprint', select all animations in its 'asset browser', right click and hit Save. The same FBX file loads fine in 4.10 with all animations.

Then I have realized, that the animations does not show up in 'Save Content' window when you restart the Unreal Engine along with all the rest changes in the project. So, I have tried just to select all animations, right click on them and 'Save', this also worked out. Thanks!

avatar image Matt.Williams Jun 27 '16 at 04:08 PM

Just a heads up, I pushed for the fix on UE-32283 to be merged into 4.12.4. Barring any unforeseen circumstances, you should see it in that hotfix.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question