Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS Certificate failed to load

I am trying to package my UE4 4.11.2 project for iOS on the computer with windows 10. I have successfully packaged iOS packages in the past, but all of the sudden, all provisions and certificated went invalid. I was able to get one of my developer certificates valid again, but not my new one. Also, all previous provisions still state 'No valid certificate found' as status; Even when bundle ID match and the correct certificate is valid.

I made my provision and certificate on Macbook Pro and emailed them and the key (.p12) to my email address, so that I could continue my UE4 editor on windows 10 to package my new project for iOS. I get this message every time I try to import the certificate. Failed to load or install certificate due to an error:'Object reference not set to an instance of an object.' I can no longer package for iOS on my windows for either certificate...

I have seen answers where the date has solved this problem or the bundle id was incorrect, but this is not the solution for my problem.. Any ideas? I have messed with this for too long now and need to get this working again...

Product Version: UE 4.11
more ▼

asked Jun 07 '16 at 06:22 AM in Packaging & Deployment

avatar image

133 11 14 19

avatar image Bamwd5 Jun 08 '16 at 10:34 PM

UPDATE: I still have only one of my iOS certificates valid (white not green) and still receive the error message when trying to import another. All of my provisions still say No valid certificate found, but when changing the date like mentioned in other posts the status does change, but not to working. After changing the date backward about a month, most say expired, some say identifier not matched but they are not the correct provision for this project so I dont want to match the identifier. When I change the date forward a month, they all still say no valid certificate found. With all changes my certificate stays valid and white now. I have tried creating new provisions and importing them and tried re-downloading the old provision. What needs to happen to get this working again??? I feel like there is something in my system settings still directing them to an old certificate? Does anybody know how to change this?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Bamwd5,

Since you made your provision and certificate on a Macbook Pro and they are causing issues on your Windows 10 machine I recommend following this guide to install your provisions and certificates directly from Apple to that specific system:

iOS Quick Start

-Steve H.

more ▼

answered Jun 07 '16 at 09:14 PM

avatar image Bamwd5 Jun 08 '16 at 07:00 AM

I have followed this documentation before.

Also, I have had success in the past with provision and certificates generated on my macbook. So because I currently have my old certificate and provision working with the "change the date" hot fix. I don't want to try to regenerate the new certificate and ruin the valid old one.

Is there a reason to believe that the Macbook generation of the certificate would be the problem? Please advise.


avatar image Steve Hardister ♦♦ STAFF Jun 08 '16 at 07:47 PM

Please review the and try the answer posted on the following thread for the same error:

Error Message: failed to load or install certificate due to an error: 'Object reference not set to an instance of an object.'

If this does not resolve your issue, post your results and we will continue to investigate.

avatar image Bamwd5 Jun 08 '16 at 07:58 PM

Unfortunately not, I exported the .p12 file from keychain and sent it over as the documentation recommends. I appreciate the thought though, but this is not the solution.

avatar image Steve Hardister ♦♦ STAFF Jun 09 '16 at 05:16 PM

Try downloading and installing the AppleWWDRCA from step 5 in the following link: iOS Dev Center For Windows: download, right-click, and choose "install"

This will update your Apple Worldwide Developer Authority Certificate if it has expired, which I expect may be the case since you stated initially that your provisions and certificates became invalid "all of the sudden."

avatar image Bamwd5 Jun 09 '16 at 05:23 PM

Hey Steve:

Thanks again. I should have mentioned in the post, I have updated the AppleWWDRCA. Still after new provisions were created no valid certificate found.

Thanks, Brad

avatar image Steve Hardister ♦♦ STAFF Jun 09 '16 at 06:01 PM

Please post a screenshot of your iOS Platform settings from your Project Settings. (You can blur out specific details as I've done here:)


iosplatform.png (92.9 kB)
avatar image Wijat Xu Jul 19 '17 at 01:06 PM

I have the same problem too!!! iosSetting

really god damn......I just can't find why.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi. I was just having this exact problem and I have a solution that might work for others if you find yourself in the same situation. When creating my .p12 file I chose not to password protect it, by just hitting enter twice when prompted to create a password while generating the .p12 file. Worked just fine after that.

more ▼

answered Dec 10 '18 at 06:14 PM

avatar image

1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question