x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

OS X XBOX One Controller Malfunction

FIrst off, let me say that Unreal is becoming my favorite gaming engine, all else pale in comparison...

However, when I use my XBONE controller with the OS X IDE, without even touching the analog joystick, the axis in the viewport start going ape sh*t. It works perfectly in Windows 10, and I can easily maneuver around the level, and I kind of prefer it vs mouse/keyboard combo. Issue only happens on my MacBook Pro Retina 15".

In OS X, if I am in perspective view, the analog joystick moves by itself without touching the controller. I can then override the movement, but as soon as I let go it doesn't seem to reset. I am using a tethered XBOX One controller with TattieBogle Xbox 360 Driver for OS X.

Additional info, the other viewports work, it's just perspective that gets this undesired behavior. Also when I compile to standalone window, or preview in the current viewport, everything works as should. It's just when i'm editing in perspective that seems to be the culprit. It's unfortunate because if this would be fixed, then I would loyally use my controller in my Mac IDE. It'd help productivity!

Product Version: UE 4.12
Tags:
more ▼

asked Jun 07 '16 at 04:47 PM in Bug Reports

avatar image

ApolloSoftware
46 2 11 9

avatar image Adam Davis STAFF Jun 07 '16 at 07:41 PM

Hi ApolloSoftware,

What software are you using for the XBOne controller on your Mac OS? Have you tried any other controllers to see if they get the same error when used? I attempted to reproduce this on a PC, however I was not able to do so.

avatar image ApolloSoftware Jun 08 '16 at 05:47 PM

Yeah PC it works perfectly, just on Mac it's messing up! It's a third party XBOX Driver for OS X. Here is the link: https://github.com/360Controller/360Controller/

avatar image ApolloSoftware Jun 08 '16 at 05:49 PM

For MAC and XBOX it's only third party drivers, M$oft doesn't officially support it, nor I doubt will they ever.

avatar image Adam Davis STAFF Jun 13 '16 at 04:16 PM

Have you tried unplugging and replugging in the controller? This sounds like a similar known issue, and this is the current workaround for the error in question.

avatar image ApolloSoftware Jun 23 '16 at 08:43 PM

tried it, still no avail

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi ApolloSoftware,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing the error, please comment with the requested information.

more ▼

answered Jun 17 '16 at 04:22 PM

avatar image ApolloSoftware Jun 23 '16 at 08:43 PM

Still a bug in 4.12.3. Tried all suggested, with all due respect, it was the first things i've tried. I've verified 360 and XBONE controllers have the same exact issue in OS X.

avatar image Adam Davis STAFF Jun 23 '16 at 08:50 PM

Does the controller work with other software? Is it an error with the third party software currently in use?

avatar image Anadin Dec 17 '17 at 05:07 AM

https://answers.unrealengine.com/questions/676643/xbox-one-s-bluetooth-controller-stops-keyboard-ent.html I also added this problem, didn't see this issue, linking to try and get it looked into

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question